Missing resources error message when execute the test scripts from Jenkins

ashokan_moorthiashokan_moorthi Posts: 21

Hi All, I am getting an error "ERROR: Missing Resources: The following symbols/resources were specified, but were not found in the workspace. Ensure they are valid and are relative to the workspace" when try to execute the SOATest scripts from Jenkins

but I am pretty sure that the resource path provided is correct.

The Jenkins are installed in Linux server and Parasoft too.

I have added the import command also before the command line execution.

still i am getting the above error. Can anyone please tell me whats wrong with setup. let me know if you need more details.

Comments

  • jakubiakjakubiak Posts: 385 admin

    Can you paste your command line arguments here so we can take a look? Also, can you provide a little info on what projects you have defined and where the .tst files live?

  • ashokan_moorthiashokan_moorthi Posts: 21

    I figured out the root cause of the issue and fixed it. Thanks for the help

  • VinayVinay Posts: 8

    Hi Ashokan, was this an environmental/configuration issue? If so, please share your experience here - it may help others.

    Thanks,

  • tapan1986tapan1986 Posts: 9

    I am getting the same error .Could you please some one help?

    I am getting an error "ERROR: Missing Resources: The following symbols/resources were specified, but were not found in the workspace. Ensure they are valid and are relative to the workspace" when try to execute the SOATest scripts from Jenkins

    but I am pretty sure that the resource path provided is correct.

  • benken_parasoftbenken_parasoft Posts: 566 ✭✭✭
    edited November 9

    but I am pretty sure that the resource path provided is correct.

    That error means it isn't. :) Perhaps you have a typo in one of your "-resource" arguments or maybe the workspace doesn't actually include the resources you are providing. To troubleshoot, you might also consider manually opening the workspace in the SOAtest UI to verify whether those resources actually show up or not (check Test Case Explorer and Navigator views).

    Please also be aware that copying resources under the workspace directory does not automatically make them resources. Any projects you want in the workspace have to be imported. Please see my other post for detail and explanation:
    CLI Import and execution

Sign In or Register to comment.