DB Tool - ORA-12519 error

tamilselvi86tamilselvi86 Posts: 7

I'm trying to connect to Oracle DB using DB Tool, when I run the test it gives me the below error. Listener refused the connection with the following error: ORA-12519, TNS:no appropriate service handler found 66000 What could be the reason ? I did try with some other connection string for same Oracle DB and it worked fine. The issue is specific to 1 set of connection string.

Comments

  • benken_parasoftbenken_parasoft Posts: 758 ✭✭✭

    Listener refused the connection with the following error: ORA-12519, TNS:no appropriate service handler found 66000

    This looks like an error returned from Oracle's JDBC driver. In other words, this error didn't originate from Parasoft or SOAtest, exactly.

    What could be the reason ?

    You can usually find information about errors from Oracle products from other resources on the web. For example, this top result from Google suggests an issue on the Oracle server side:
    http://www.dadbm.com/oracle-listener-refused-connection-ora-12519-troubleshooting/

    In other words, I'm not sure this error is indicative of misconfiguration on client (SOAtest) side. You may need to get in touch with your DBA about this.

  • tamilselvi86tamilselvi86 Posts: 7

    Checked with the Oracle guys and they said the parameters are set fine in the DB. though I tried a different option, instead of using the SID I used the service name in the URL in the below format and it worked. (DB Tool).

    URL - jdbc:oracle:thin:@cowht013-scan.bankofamerica.com:49125: UBEDBH01_1

    instead used below

    URL - jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=cowht013-scan.bankofamerica.com)(PORT=49125))(LOAD_BALANCE=yes)(CONNECT_DATA=(SERVER=DEDICATED)
    (service_name=UDPDBD01_SVC_01.bankofamerica.com)(FAILOVER_MODE=(TYPE=SELECT)(METHOD=BASIC)(RETRIES=10)(DELAY=5))))

    The issue still persist when we use Database data source, both SID and Service name doesn't work there. Its just strange that only for certain set of connection string its causing this issue.

Sign In or Register to comment.