SOA Test 9.9 unix installation- how to intercept http traffic via proxy

aswakaswak Posts: 6

Hi,
I have a SOA Test installation on Unix , version 9.9. i have updated the local setting file which in our case is propertie file with values :-
proxy.enable.proxy=true
proxy.use.system.proxy.configuration=false
proxy.http=localhost
proxy.http.port=7071

On the same box i have installed ZAP proxy and was attempting to intercept it , however nothing is going via zap and i see activity in the logs. Where exactly do we need to update SOA Test so that traffic can be routed via ZAP proxy.?

Tagged:

Comments

  • jakubiakjakubiak Posts: 371 admin

    Are you running SOAtest via CLI, or via UI? If doing it via UI, then you need to set the proxy settings in the preferences within the UI. If doing it via CLI, then we need to double-check that you are configuring and passing the localsettings file properly.

  • aswakaswak Posts: 6
    edited August 17

    Pasted Code below

  • aswakaswak Posts: 6

    for some reason the xml tags did not go through in the post

  • aswakaswak Posts: 6

    Hey jakubiak , I have the installation on unix.Its running on headless mode via CLI. I am running the soatest via maven, mvn -P mvn -P smoke-test verify , in the maven profile i have specified the parameters as :- <!--profile> <id>smoke-test-Jboss</id> <build> <plugins> <plugin> <groupId>Parasoft</groupId> <artifactId>maven-parasoft-plugin</artifactId> <version>3.12</version> <executions> <execution> <phase>integration-test</phase> <goals> <goal>eclipse</goal> <goal>soatest</goal> </goals> </execution> </executions> <configuration> <soatestHome>/app/release/gs/parasoft/soatest/9.9</soatestHome> <importArguments>/app/Nightly_Functional/qa</importArguments> <localsettings>resources/properties/functional-test.properties</localsettings> <config>user://Example Configuration</config> <environment>ABC</environment> <resources> <resource>qa/SmokeTest.tst</resource> </resources> <vmargs> <vmarg>-Duser.name=${env.SOATESTUSER}</vmarg> <vmarg>-Djsse.enableSNIExtension=false</vmarg> </vmargs> </configuration> </plugin> </plugins> </build> </profile--!>

  • aswakaswak Posts: 6

    From above <localsettings>resources/properties/functional-test.properties</localsettings>
    that file contains the proxy information ....is this a valid way?

  • aswakaswak Posts: 6

    Any update jakubiak ?

  • jakubiakjakubiak Posts: 371 admin

    In general that looks okay, although I am not an expert regarding the Maven plugin. I would try to debug this by trying to get it to work from the desktop first; configure the proxy settings in the UI and then run a test manually to verify that the ZAP proxy is receiving the traffic. I would also check whether your application is being run over HTTP or HTTPS - the settings as you have configured them will only work for HTTP. If your site is using SSL, then you also need to set the property proxy.same.proxy.server.for.all.protocols or the properties proxy.secure and proxy.secure.port.

    If you still can't get it to work you may want to reach out to Parasoft support.

  • benken_parasoftbenken_parasoft Posts: 552 ✭✭✭

    proxy.enable.proxy=true
    proxy.use.system.proxy.configuration=false
    proxy.http=localhost
    proxy.http.port=7071

    When I search the docs, I only see these mentioned under "Deploying the SOAtest and Virtualize Server WAR File". The "localsettings" properties file for soatestcli takes a different list of properties and I'm not sure these ones are supported there. The maven plugin is just a driver/launcher for soatestcli.

    If I remember correctly, I think the maven plugin generates an on-the-fly workspace in some temporary location for running soatestcli (the "-data" argument). I haven't tried this but it might be possible to add an execution to your pom to add the proxy settings into the main SOAtest preference file in the workspace directory under ".metadata/.plugins/org.eclipse.core.runtime/.settings/com.parasoft.xtest.common.eclipse.core.web.prefs".

  • jakubiakjakubiak Posts: 371 admin

    @benken_parasoft you are correct. Please see https://forums.parasoft.com/discussion/3512/setting-up-the-proxy-in-the-localsettings-property-file for posts on how this can be automated without using localsettings.

Sign In or Register to comment.