How to use SOATest Extension Tool with maven

Sourabh25Sourabh25 Posts: 37

Hi,

I am trying to use soatest Extension tool with maven. So i added the dependency in the maven and now I try to load that class in the Extension tool,. However I am not able to.

I am loading the class but then also I am not able to see the .methods in the dropdown.
Isnt there a way where I dont have to manually configure the classpaths

Tagged:

Comments

  • Sourabh25Sourabh25 Posts: 37

    Could anyone help me here?

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 158 ✭✭
  • Sourabh25Sourabh25 Posts: 37

    I tried adding the system.properties.classpath but it is not helping. I have given the path of the jar in the m2 repository. Not sure what I am doing incorrectly

  • jakubiakjakubiak Posts: 447 admin

    For the purposes of Extension Tools or scripting, SOAtest has no knowledge of Maven repos. You will need to add the jars to your system properties as described in the forum post referenced by @Ireneusz Szmigiel. The easiest way to do this would be to copy the jars into the /TestAssets/system_jars folder, although specifying the system.properties.classpath will work too. Keep in mind that you need to be very careful with the path syntax when specifying the system.properties.classpath.

  • Sourabh25Sourabh25 Posts: 37
    edited March 2018

    system.properties.classpath=C:\Users\username\.m2\repository\com\abc\selenium\logtransactions\1.6-SNAPSHOT\logtransactions-1.6-SNAPSHOT.jar

    Does this look correct. I have added this in the localsettings file

  • jakubiakjakubiak Posts: 447 admin

    No it does not - it is missing backslashes before the colon and the path separators should be double backslashes (not sure if the forums removed it from your post). If you look at what was done in the forums post referenced by @Ireneusz Szmigiel, you will see that it should be
    system.properties.classpath=C\:\\Users\\username.m2\\repository\\com\\abc\\selenium\\logtransactions\\1.6-SNAPSHOT\\logtransactions-1.6-SNAPSHOT.jar

    Based on the jar you are referencing, it appears that you might be trying to run a Selenium script from inside SOAtest. Note that the Parasoft marketplace has a Selenium runner tool that is able to run Selenium scripts from SOAtest easily. You may want to check it out.

  • Sourabh25Sourabh25 Posts: 37
    edited March 2018

    I updated system.properties.classpath=C\:\\Users\\username\\.m2\\repository\\com\\abc\\selenium\\logtransactions\\1.6-SNAPSHOT\\logtransactions-1.6-SNAPSHOT.jar

    but still I am not able to see the methods of the class in the Extension Tool. :(

  • jakubiakjakubiak Posts: 447 admin

    Can you try copying the jars to the system_jars folder just to see if that will work?

    You may want to consider contacting Parasoft support since it's not clear what you are doing wrong.

  • Sourabh25Sourabh25 Posts: 37
    edited March 2018

    When I do the below steps (Parasoft - Preferences - System Properties - Add java project)and then I reload the class, I am able to see the methods in the dropdown:

    So i think the parasoft soatest is working fine. But when I am building from maven , I am not able to see the methods in the dropdown

  • Sourabh25Sourabh25 Posts: 37

    Also , I have two perspectives.. java and parasoft soatest. So i am building the project through maven in the Java perspective but in soatest perspective, i don't see any thing which connects it to the maven dependencies

  • jakubiakjakubiak Posts: 447 admin

    Correct - as I mentioned previously, SOAtest itself is not aware of the Maven dependencies. So you need to connect it to the jars via one of the other suggested mechanisms.

  • Sourabh25Sourabh25 Posts: 37

    I tried this
    system.properties.classpath=C:\Users\username\.m2\repository\com\abc\selenium\logtransactions\1.6-SNAPSHOT\logtransactions-1.6-SNAPSHOT.jar.

    It has not worked.

    The 2nd way is to add it to system_jars. So I have a project in java perspective, under that you want me to add the folder system_jars and then add the jars from the maven dependencies. Am I following it correctly?

  • jakubiakjakubiak Posts: 447 admin

    This forums post explains how to do it - add a "TestAssets" project to your SOAtest workspace. Then add a directory within that project called "system_jars" and copy the jars into that location. Restart SOAtest and then try it.

  • Sourabh25Sourabh25 Posts: 37

    I am not able to resolve this. :(

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 158 ✭✭

    @Sourabh25

    Could you please describe what you did?Which approach you have used?
    Which version of SOAtest?
    We need more details to be able to help you? Do you still see the same error?
    Do you have it working in SOAtest?
    If yes, what happens if you are trying to use the same workspace in maven? executed by the same user as GUI?
    If you can not share details on forum, please contact Parasoft Support Team.

    --
    Ireneusz Szmigiel
    http://www.catb.org/esr/faqs/smart-questions.html

  • Sourabh25Sourabh25 Posts: 37

    I am using 9.10 version of soatest.

    I have created a maven project with soatest. Now when I am executing a plain soatest , it is working fine. But now I want to use Soatest Extension tool. Then I am trying to load a class which is added in the maven dependency, but while doing so, the methods of the class are not getting populated in the dropdown.

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 158 ✭✭

    @Sourabh25

    as @jakubiak mentioned, SOAtest is not aware about maven dependencies.
    Please answer following questions which may help us understand your configuration better:
    1.Do you use the same workspace in maven as in SOAtest GUI ?
    2.As you are using v9.10 then system_jars should work for you. Did you try approach suggested by @jakubiak?
    3.As such jar has been created by maven, are you sure that you have it in system_jars directory before you are starting SAOtest task?
    4.Can you publish in this thread localsettings.properies file used by you in SOAtest task?

    --
    Ireneusz Szmigiel
    http://www.catb.org/esr/faqs/smart-questions.html

  • Sourabh25Sourabh25 Posts: 37
    1. Yes both the workspace is same.
    2. I was not able to copy the dependency jars from to the systems_jar

    4 localsettings.properties

    Exported local settings

    Wed Mar 14 10:05:41 EDT 2018

    authors.mappings.location=team
    concerto.data.port=32323
    concerto.enabled=false
    concerto.log_as_nightly=false
    concerto.reporting=false
    concerto.user=!frictionlessbsd
    concerto.web.port=80
    console.verbosity.level=
    datasources.global.location=local
    env.manager.notify=true
    general.project=Default Project
    license.network.host=10.253.210.135
    license.network.port=2002
    parallel.no_memory_limit=false
    report.active_rules=false
    report.archive=false
    report.associations=false
    report.authors_details=true
    report.contexts_details=false
    report.custom.extension=html
    report.developer_errors=true
    report.developer_reports=true
    report.failed_tests_only=false
    report.format=html
    report.generate_htmls=true
    report.location_details=false
    report.mail.on.error.only=false
    report.mail.password=
    report.mail.port=25
    report.mail.security=STARTTLS
    report.mail.server=
    report.mail.subject=${tool_name} Report - ${config_name}
    report.mail.username=
    report.metrics_details=true
    report.setup.problems=bottom
    report.suppressed_msgs=false
    report.tcdetails=false
    report.test_suites_only=true
    scontrol.git.exec=git.exe
    scope.local=true
    scope.sourcecontrol=false
    scope.xmlmap=false
    scripting.timeout.minutes=10
    security.trust.all.certificates=true
    security.use.default.java.cacerts=false
    session.tag=${config_name}
    soatest.license.custom_edition_features=RuleWizard, Command Line, SOA, Web, Server API Enabled, Jtest Connect, Stub Desktop, Stub Server, Message Packs
    soatest.license.network.edition=custom_edition
    soatest.license.use_network=true
    tcm.server.accountLogin=false
    tcm.server.enabled=false
    tcm.server.port=18888
    techsupport.advanced=false
    techsupport.auto_creation=false
    techsupport.item.environment=false
    techsupport.item.general=true
    techsupport.mail.body=Help required.
    techsupport.mail.subject=Technical Support Archive
    techsupport.send_email=false
    techsupport.verbose=false
    techsupport.verbose.scontrol=false
    system.properties.classpath=C:\Users\username\.m2\repository\com\abc\selenium\logtransactions\1.6-SNAPSHOT\logtransactions-1.6-SNAPSHOT.jar

Sign In or Register to comment.