Backward compatibility

roshansukurroshansukur Posts: 1

Hi,

I have created scripts in 9.10 and have it in the team share . But my counterpart teams are using SOA 9.9 version and uploading their scripts.I m not able to open the services Soa 9.9 (.tst files) in 9.10 version .Is it possible for me to have backward compatibility of my 9.10 scripts to 9.9 version?

Any help is much appreciated!!

Thanks,
Sai

Comments

  • benken_parasoftbenken_parasoft Posts: 394 ✭✭✭
    edited October 2017

    SOAtest can open tst files saved in a newer version as long as both the major and minor version number are the same. For example, a project saved in SOAtest 9.10.3 can open in SOAtest 9.10.2, provided that the project from 9.10.3 isn't using any new features didn't exist in 9.10.2.

    In your case, the minor version number is different (9 vs 10). You will need to upgrade the other installations to 9.10 or re-create the projects in 9.9.

    I should note that SOAtest can always read project files saved in an older version.

Sign In or Register to comment.