Storing XML as a column in a Writable Datasource Slowness

reactancexlreactancexl Posts: 86

there is somewhat of a similar question posted earlier on this forum about the "Slowness" of the datasource. I have tried all the suggestions that were listed, (Clearing Tasks, heap size, limit amount of tests in workspace etc.) and it takes "forever" to bring up and sometimes it does not come up. I only have two rows in the DS. So what would be a good workaround to this? Any suggestions? thx

Comments

  • benken_parasoftbenken_parasoft Posts: 399 ✭✭✭

    To the best of my knowlege, what you describe is not typical and therefore is likely specific to your environment. You would need do some troubleshooting to isolate what is causing the undesired behavior, at what point the problem starts to happen. You may want to reach out to Parasoft Support for assistance.

  • reactancexlreactancexl Posts: 86

    It is slow when one of the columns contains XML. It seems like it takes time parsing thru the XML. thx

  • reactancexlreactancexl Posts: 86

    Here is one of the errors after I close it down. (Java was started but returned exit code=-805306369”)

  • reactancexlreactancexl Posts: 86

    I think I have figured out the issue. It was the XSLT that caused the XML to contain spaces in between the nodes that was represented in the writeable DS. I was able to open the DS if it contained only 1 column which was the “XML Message”, that is how I found the spaces in between the nodes. When I added another text column is when I was not able to open. Still was valid xml but Parasoft Writable Datasource does not like it. For Instance
    text text

    The Omit declaration Line caused the issue.

    Old Causing issues
    <?xml version="1.0"?>


    New working
    <?xml version="1.0"?>

    texttext

    Now I can have several text columns along with the column that contains the xml. thx

  • reactancexlreactancexl Posts: 86

    Sorry, for some reason the text did not come over. Here it is. This is the line I removed
    xsl:output omit-xml-declaration="yes" method="xml"

Sign In or Register to comment.