How to Change the java versions 1.7 in parasoft soatest 9.10?

hpatelhpatel Posts: 16

I have certain jar files to be loaded into "Parasoft Preferences > System Property" which requires JAVA "1.7" but SOATest 9.10 have "1.8"... so i need to downgrade Java to 1.7... so i can submit a claims. Any suggestion?

Comments

  • jakubiakjakubiak Posts: 360 admin

    Java 8 is able to use jar files that were compiled with Java 7, so you should have no problem adding your jars built with Java 7 into SOAtest and using them in your test scenarios. However, if you'd still like to run SOAtest with Java 7, see this post.

  • hpatelhpatel Posts: 16

    @jakubiak thanks much, however i'm seeing some issues with compatibility therefore i have to downgrade it to 1.7.

  • hpatelhpatel Posts: 16

    I tried same kept Zjava_home as below, however getting "Version 1.7.0 of the JVM is not suitable for this product. version 1.8 or greater is required"

    -Zjava_home "C:\Program Files\Parasoft\Test\9.9\plugins\com.parasoft.xtest.jdk.eclipse.core.win32.x86_64_1.7.0.76\jdk"

  • jakubiakjakubiak Posts: 360 admin

    Can you be more specific? Where is that message being reported?

  • jakubiakjakubiak Posts: 360 admin

    Actually, one of my colleagues told me what the problem probably is. SOAtest 9.10 ships with Eclipse 4.6, which requires Java 8 in order to run. If you need to run with Java 7, then you would need to get Eclipse 4.5 or older, install SOAtest via update site, and configure that Eclipse to run with Java 7. However, I'm still surprised that this would be necessary. Could you tell us what error you are seeing when you use Java 8 with your jars?

  • hpatelhpatel Posts: 16

    @jakubiak thanks much again, sure here is more detail with pic...
    i updated to point java 7 @ property of desktop shortcut...

    then launch the exe from desktop which should open the workspace instead showing below msg...

  • hpatelhpatel Posts: 16

    @jakubiak regarding ...(Can you be more specific? Where is that message being reported?)

    below is the err i'm getting with 9.10 (java 8)...where as jar file which i loaded to soatest property files required java 1.7...

    Error Message:
    java.lang.NoClassDefFoundError: sun/io/MalformedInputException class was not found, please make
    sure the appropriate jar files are on your CLASSPATH

  • benken_parasoftbenken_parasoft Posts: 522 ✭✭✭
    edited June 2017

    Are you using WebSphere? I'm aware of this bug with some older versions of WebSphere thinclient jars:
    http://www-01.ibm.com/support/docview.wss?uid=swg1IX90160
    https://stackoverflow.com/questions/27903038/sun-io-malformedinputexception-when-trying-to-remotely-connect-to-jms-queue-on-w

    As mentioned, if you need to run with Java 7 then you also need to downgrade the Eclipse. You'll need to install your own Eclipse 4.5 (aka "Mars"). SOAtest can be installed into Eclipse from a p2 update site archive (available from Parasoft).

    Otherwise, see if you can apply the fix pack mentioned in the IBM Support article, using newer version of the thinclient jars.

  • hpatelhpatel Posts: 16
    edited June 2017

    @benken_parasoft thanks much...yes using WebSphere...
    can you provide more details about ..."SOAtest can be installed into Eclipse from a p2 update site archive (available from Parasoft)."

  • benken_parasoftbenken_parasoft Posts: 522 ✭✭✭

    You need reach out to your contact with Parasoft for installation guides and download instructions.

  • jakubiakjakubiak Posts: 360 admin

    Once you receive the update site from Parasoft, there is an installation guide in the SOAtest installation directory under the manuals folder that explains how to install the update site.

Sign In or Register to comment.