[HELP] REST URL Databank Not Extracting value from Path

awallsawalls Posts: 15

Hi,

I am running into an issue where the virtualized service I created is supposed to extract a value from the URL path and make some status change in data repo. For some reason the value being sent in the request isn't being extracted by the REST URL Databank.

I am using Parasoft version 9.10

Request Template

Data Source Correlation

REST URL DATABANK

Transport Header REST URL DATA BANK

CRUD Operation

Expected response created for debugging

Actual Response

Parasoft Event Log

Also the CRUD operation isn't occurring because the value isn't being extracted.

Thanks in advance for the help!

Comments

  • williammccuskerwilliammccusker Posts: 528 ✭✭✭

    Hi,

    Have you tried on a simpler case to see what the URL data bank is extracting? Or what the actual path is at runtime? Could it be that the actual path at runtime is shorter than is in the request template?

  • awallsawalls Posts: 15

    Hi William,

    The simpler case to debug was sending the account number extracted from the request path in the response, (which returns an empty string)

    As far as the path at runtime, they've all been the same length of the request template.

    Path received at runtime from event logs, The 7th element in the path is the account number

    Datasource correlation set to the 7th index

    REST URL Databank extracting from the 7th element as well

  • williammccuskerwilliammccusker Posts: 528 ✭✭✭

    Hi,

    Is the first screenshot the URL path as shown in the request message event? Could you share the simple pva file that you setup to debug this? I suspect there is something going on with either the settings in the pva file or a mismatch between the expected request and the actual request.

  • awallsawalls Posts: 15

    Hi William,

    There is no simple pva file, this is all within the pva file of the system I'm virtualizing which includes some private data. Can you give me some steps of direction to look for in debugging this? I'm not sure if setting up a separate .pva file will have all the context of what's currently happening with what's already created.

  • williammccuskerwilliammccusker Posts: 528 ✭✭✭

    Hi,

    Have you tried monitoring the virtual asset? Here is some documentation about it

    https://docs.parasoft.com/display/VIRT9105/Gaining+Visibility+into+Server+Events

Sign In or Register to comment.