FTP: Upload multiple files within SOAtest

dgoedhdgoedh Posts: 16

Hi fellow Parasoft users, this is my first forum post: I'm Daniel from Amsterdam NL and already using Parasoft SOAtest for a few years. Currently working on improving our framework, that's mostly hung up on external VB scripts, to make more use of intrinsic SOAtest functionality as it is designed to be used.
I try to use the FTP client, which is good for e.g. cleaning a remote folder and putting/getting a single file. However for our tests we also want to be able to upload multiple files in one go from a local folder, which would require an ftp mput possiblitity,

Has anybody found a workaround within SOAtest to cater for multiple file upload? Is there an external (java) building block that can do that, or is the only way the use of e.g. the Extension Tool for the execution of an external script with winscp etc.

Thanks in advance.

Regards,

Daniel

Tagged:

Comments

  • benken_parasoftbenken_parasoft Posts: 691 ✭✭✭

    Without support for "mput", is it not sufficient to simply add multiple "put" commands into the Commands table? Aside from that, you might want to take a look at the "SFTP Client Tool" tool from the Parasoft Marketplace in case it happens to handle this (I haven't tried). The docs simply say "Any standard SFTP commands can be used—check the documentation for your server to see which commands are available". Alternatively, if you decide to invoke an external tool like winscp, then I'd recommend using the External Tool instead of the Extension Tool.

  • dgoedhdgoedh Posts: 16

    Hi, thanks for the advice. I am opting now for SFTP Client Tool from the market place, in which wild cards should be possible, to cater for multiple upload/download. However I am struggle to get it working. I have configured ssh private/public keys according to https://www.jscape.com/blog/setting-up-sftp-public-key-authentication-command-line, using cygwin. This way I get an id_rsa, id_rsa.pub and known_hosts file. I have put the absolute paths to id_rsa and known_hosts in Key Store File resp. Known Hosts File on the SFTP client Connection Settings fields, but when I try to run a test in SOA test I get an error: Error connecting to SSH server. UnknownHostKey: 10.xxx.yyy.zz. RSA key fingerprint is
    e9:etc.
    Any idea how to solve this? Within cygwin I can use sftp on the client machine after entering the key paraphrase. Or should I set up the private/public keys without the key paraphrase for SOAtest SFTP client?
    Thanks in advance.

    Regards, Daniel

  • jakubiakjakubiak Posts: 517 admin

    Since the SFTP tool doesn't have a way to enter the key paraphrase, I would recommend setting up the private/public keys without the key paraphrase and see if that works. There is a good chance that that is the problem.

  • dgoedhdgoedh Posts: 16

    Thanks for the advice. I reset my private/public keys without providing a key paraphrase. At first this gave me the same error (UnknownHostKey), however subsequently removing the path to Known Hosts File in connection settings cleared the sky for me. Now I am able to execute sftp commands to up and download multiple files among others, without errors.

Sign In or Register to comment.