Variable cannot be resolved when run using soatestcli.exe

WagnerWagner Posts: 9

I have a test scenario of two tests. The first, sends a value A in a request, and gets back a value B in the response. I store the two pairwise in a writable data source (an XML databank) on the first test. The second test uses the value B in its subsequent request. I have the writable data source configured to overwrite per iteration.

When I run the test scenario in SOATest, it passes fine.

However, when I run the test scenario through soatestcli.exe, the second test fails due to being unable to resolve the variable B.

Any ideas on how to fix this?

Comments

  • WagnerWagner Posts: 9

    I tried to work around this by instead of routing the value to a writable data source column using the XML data bank, having the value B go to a test scenario environmental variable. This didn't work in SOATest, nor soatestcli.exe.

    However, instead I tried routing it to a custom column name, and that seems to work in both SOATest and soatestcli.exe. --I don't know where it's being stored, because I deleted the writable data source, but it's going somewhere.

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 146 ✭✭

    Hi Wagner,

    could you post your tst field on forum?

    --
    Ireneusz Szmigiel
    http://www.catb.org/esr/faqs/smart-questions.html

  • WagnerWagner Posts: 9

    Hi Ireneusz,

    I'm not sure exactly which field you're asking for, my apologies.

Sign In or Register to comment.