Empty CppTest Result Logs

dbrenner74dbrenner74 Posts: 2

Hi,
I'm currently using Wind River Workbench 3.3.6.1 and C++test for Eclipse 9.5. When I run my auto-generated unit tests (compiled with the ccpentium) against a vxsim target everything works great. My cpptest_results clog/tlog files are created and I can generate my reports.

However, when I run through a Target Server (compiled with PPC compiler) the logs are empty. I had to modify the "Build Vxworks Test Module - DKM (TSFS)" slightly to even get the files created. I believe the target board must be able to have access to the host file system. MyCustom Flow now has lines like this below based upon access granted by the FTP server and my "home" directory

        testLogFile="host:/Logs/cpptest_results.tlog"
        covLogFile="host:/Logs/cpptest_results.clog"

Any ideas where I can start troubleshooting?

Thanks,
Dan

Tagged:

Answers

  • dbrenner74dbrenner74 Posts: 2

    Turns out it was our FTP server not giving us proper permission to write to host system drive. Parasoft's engine runtime code silently fails to open the stream when permissions are incorrect.

Sign In or Register to comment.