Could not find a valid Message Responder to respond to this request.

Hi Team,

I have deployed calculator wsdl in PARASOFT Virtualize successfully,But i am getting the below error message while calling the deployed endpoint?
Wsdl :

error message:

Could not find a valid Message Responder to respond to this request.
Be sure you have a Message Responder with correlation criteria that match this message.
1 virtual asset attempted to process this request:
Correlation type: Transport
[criteria=SOAPAction, expected=add, actual=[NOT_FOUND], results=false]
Correlation type: Transport
[criteria=SOAPAction, expected=divide, actual=[NOT_FOUND], results=false]
Correlation type: Transport
Disabled : true
Correlation type: Request Body
Empty Payload : false
Correlation type: Transport
[criteria=SOAPAction, expected=multiply, actual=[NOT_FOUND], results=false]
Correlation type: Transport
[criteria=SOAPAction, expected=subtract, actual=[NOT_FOUND], results=false]
Correlation type: Transport
[criteria=SOAPAction, expected=subtract2, actual=[NOT_FOUND], results=false]

Request :
Please help me on this



  • Hi swapna, can you please post your .tst and .pva file?

  • swapna0707swapna0707 Posts: 41
    edited January 2018

    Hi @hzzz ;

    I have attached .pva file in this post and have not created the .tst file ,I just trying to hit the end point from the browser.this is the first example which I am doing in parasoft virtualize.

    Kindly look into it and correct me if i missed any of the steps.


  • benken_parasoftbenken_parasoft Posts: 1,002 ✭✭✭
    edited January 2018

    I just trying to hit the end point from the browser

    A web browser will not send an expected SOAP request. The responders are configured to correlate with a SOAP message, matching based on SOAPAction header based on what I infer from an earlier comment.

    You would need to send a valid SOAP request from a real SOAP client that knows how to generate a proper SOAP request with expected SOAPAction header.

    Alternatively, if you were trying to test something from a browser, perhaps you want to Virtualize a REST API instead of a SOAP API?

  • swapna0707swapna0707 Posts: 41

    Thanks @benken_parasoft for the valuable info.

    I have tried to Virtualize a REST API and its working fine now.


  • saish1111saish1111 Posts: 1
    edited January 2019

    Hi Swapna, Everyone,

    I have deployed a virtual asset in Parasoft and getting the same error. The request is sent by the application to the parasoft server but it still throws the error. Can anyone help me on this issue?

  • tsworldtsworld Posts: 14

    This happens when certain parameters or url path is expected in request but not hit like that.

    Follow the steps to fix issue:-

    • Open Virtual Assets or .pva file that has issue
    • Goto tab "Responder Correlation"
    • Then on left we see menu items Transport, Request Body, URL Parameters, URL Path, HTTP Methods, Custom and ISO 8583 Correlation

      • We need to unselect option "Enable correlation" under URL Parameters / URL Path
Sign In or Register to comment.