Test suite failing

sujatssujats Posts: 1

I have multiple tests inside Test suite, all test are passed while running them separately. all of them fails when i run it together. Like I selected Test suite-> Executed, all test fails instantly. When i run the test individually its passed and also it took sometime to complete. i tried test flow->adding time etc..it didnt work. please provide me a solution to execute whole test suite which can be executed successfully.


  • OmarROmarR Posts: 219 admin

    Hello sujats,

    What error do you see in the Quality Tasks?
    Are your tests dependent on each other or a shared data source?
    If so, try running the Parent Test Suite with a different Test Relationship to have the tests run as a group:

    More info on Test Relationship can be found here.

  • KesaryKesary Posts: 5

    My test suite is getting failed when I run together as a suite. Tried all the ways running from parent suite or running the complete .tst file. Only that particular test suite is getting failed and giving error as "Test did not fail during 2 loops." . But when I run individually the scenarios they are getting passed. Not sure what the issue is.

  • jakubiakjakubiak Posts: 570 admin

    It sounds like you have set the test suite option "Loop until test fails" with a maximum number of loops set to 2. To verify this, open the editor for the test suite that is failing, and go to Execution Options > Test Flow Logic. Check the "Flow type" option - it sounds like you have it set to "While pass/fail" but want it to be "None".

  • KesaryKesary Posts: 5

    Perfect. That worked I changed the "Flow Type" to "None" and My tests are running!!!!! Thank you

Sign In or Register to comment.