Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

Licensing: Unstable/changing Machine-ID

Billy McMullin
Billy McMullin Posts: 63 admin
edited June 2017 in C/C++test

Changes in the network environment may affect the interface that is used to compute your machine ID (used to identify your license) and result in machine ID instability. You can use the PARASOFT_SUPPORT_NET_INTERFACES environment variable to specify a stable interface and prevent the machine ID from floating.

  1. Set up the PARASOFT_SUPPORT_NET_INTERFACES environment variable.
  2. Set the variable value to a stable Ethernet network interface. Do not use virtual, temporary or loopback interfaces.
  • On Windows: Set the value to the MAC address of your network card. You can use the ipconfig -all command to obtain the address. Example:

SET PARASOFT_SUPPORT_NET_INTERFACES=00-10-D9-27-AC-85

  • On Linux: Set the value to one of the network interfaces from the "inet" or "inet6" family. For Example: You can use the ifconfig command to obtain the list of available interfaces. Example:

export PARASOFT_SUPPORT_NET_INTERFACES=eth1

If the problem persists, you can obtain diagnostic information by setting up the environment variable PARASOFT_DEBUG_NET_INTERFACES and setting its value to true. This will print to the standard output the checking procedure that can be shared with technical support , as well as the interface that is used to compute your machine ID. The interface will be marked with the [SELECTED] prefix.

Comments

  • brian_nuckles
    brian_nuckles Posts: 32 admin
    edited February 2018

    Manual Reset of MachineID-0 on Ubuntu 16.04

    1. Navigate to /etc/default and edit the file named 'grub'

    2. Replace the line GRUB_CMDLINE_LINUX=""
      with the line GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"

    3. Rebuild the grub configuration file:

      sudo grub-mkconfig -o /boot/grub/grub.cfg

    4. Update grub with: sudo update-grub

    5. Add these lines to the bottom of /etc/network/interfaces

      auto eth0
      iface eth0 inet dhcp

    6. Reboot your machine and check your Machine ID from the License Page.

      Find more information here: https://askubuntu.com/
      questions/767786/changing-network-interfaces-name-ubuntu-16-04
      and here: http://www.itzgeek.com/how-tos/mini-howtos/change-default-network-name-ens33-to-old-eth0-on-ubuntu-16-04.html

  • Rich
    Rich Posts: 31 ✭✭

    There is another cause of this sort of problem: A disconnect between the host name as reported by hostname(1) and uname(1).

    Correcting this will resolve this problem completely, no matter what network interfaces are available, (provided that there is at least one network interface which is IPv4 enabled.)

    See: http://man7.org/linux/man-pages/man1/uname.1.html
    And: http://man7.org/linux/man-pages/man1/hostname.1.html

    This is easily resolved by adding an entry, (or an alias), to the /etc/hosts file. No reboot is required.

    See: http://man7.org/linux/man-pages/man5/hosts.5.html

  • Rich
    Rich Posts: 31 ✭✭

    Or, it may be as simple as making sure that /etc/hostname contains the same name as uname -n

    $ uname -n
    raddish
    $ cat /etc/hostname
    raddish

  • uname
    uname Posts: 3

    Still facing this problem on Windows. From time to time it happens and machine id is another from one that belongs to key.

    I have set PARASOFT_SUPPORT_NET_INTERFACES from real one value in my environment variables, but it didn't solve the problem.

  • uname
    uname Posts: 3

    Well, I fixed this problem with support.
    I had to set ethernet mac address as value of PARASOFT_SUPPORT_NET_INTERFACES instead of setting the wireless mac.