Getting license error when starting Virtualize Server in CLI mode

tarunsahutarunsahu Posts: 8

Hi, I tried putting my license details in properties file and ran below command :

virtualizecli.exe -startServer -locals
ettings "C:\SOAVirtualize\VirtualizeExportLocalSettings.properties"

However, I still get license not valid/applicable. Can someone please help here.

I am using this setting in properties file :

virtualize.license.network.edition=professional_edition
virtualize.license.use_network=true

and here is the error from command prompt:

C:\Program Files\Parasoft\Virtualize\9.10>virtualizecli.exe -startServer -locals
ettings "C:\SOAVirtualize\VirtualizeExportLocalSettings.properties"
virtualizecli: Version 9.10.3.20170927 -- Copyright (C) 2016 Parasoft Corporatio
n
virtualizecli: Using default workspace "C:\Users\someuser\parasoft\virtualize_
workspace"
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; sup
port was removed in 8.0
This license is not applicable for the SOAtest/Virtualize Server.
Server license is required
[Virtualize] writing VirtualAssets.xml
[Virtualize] Writing to C:\Users\someuser\parasoft\virtualize_workspace\Virtua
lAssets\VirtualAssets.xml
[Virtualize] 01/18 11:55:34 AM Shutting down current deployments.
01/18 11:55:34 AM Shutting down current deployments.
[Virtualize] 01/18 11:55:34 AM Shutdown of deployments finished.
01/18 11:55:34 AM Shutdown of deployments finished.

Answers

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 135 ✭✭

    Hi tarunsahu

    option virtualize.license.use_network=true is used to use license from License Server.
    If you have local license you should set mentioned option to false.
    If you have License Server and correct license, please check if you have disabled options "Clients should start deactivated"

    If you can not resolve this problem, please contact with Parasoft Support Team.

    Ireneusz Szmigiel

Sign In or Register to comment.