getting the License issue while hits the virtual service in the Parasoft

swapna0707swapna0707 Posts: 35
edited May 11 in Virtualize

Hi Team,
I am getting the below error message while hits the service using Parasoft Virtual tool for the service (http://soaptest.parasoft.com/calculator-02.wsdl) and mock service as http://localhost:9080/glue/calculator .
The number of licensed hits per day has been reached. Use a license with a higher limit, or wait until tomorrow when the per day limit has been reset to process additional requests.

Kindly take a look and help me on this.

Thanks,
Swapna

Comments

  • hzzzhzzz Posts: 11

    Hi Swapna, the free Community Edition Virtualize does have a limit on hits per day. If you reach that limit you will have to wait until the next day, or buy a license with higher limit.

  • OmarROmarR Posts: 186 admin

    Hey Swapna,

    What is your current hit count for your local server? You can check this by double-clicking the "Local machine" node under the Virtualize Server view.

    As @hzzz stated, it may be that you have reached the amount of hits your tool is currently licensed for.

  • swapna0707swapna0707 Posts: 35

    Hi @OmarR, @hzzz

    please find the screenshot for local server configuration as below.

    .

    now can you tell me steps to proceed further on this.

    Thanks,
    Swapna

  • swapna0707swapna0707 Posts: 35

    Hi Team,

    how do we know the parasoft Virtualize Licence is it installed in my machine?

    Please help me on this.

    Thanks,
    Swapna

  • Hi Swapna,

    Do you use Parasoft Virtualize Community Edition? As @hzzz stated, Community Edition has a hit limit per day.

    Otherwise, the current license settings of your Parasoft Virtualize instance can be checked in Virtualize GUI, under Parasoft menu> Preferences...> License section. If you have multiple Parasoft products installed, open the tab for Parasoft Virtualize:

    You may want to check with your IT team about: the licenses your organization has, hit limits for these licenses, and about Parasoft License Server hostname, if used by your organization.

    More details about Parasoft Virtualize licensing and how to configure the license can be found here:
    https://docs.parasoft.com/display/VIRT9103/Licensing
    In particular:

    • If you are using local / machine-locked licenses, you may want to check "Using a Machine-Locked License" section on the page above.
    • If you are using Parasoft License Server, go to "Using a DTP License" section.
  • swapna0707swapna0707 Posts: 35

    Hi @Bogdan Czwartkowski ,

    Thanks for your valuable explanation and followed the steps which you had specified and I am able to find the license details in my machine.

    Thanks a lot.

    Thanks
    Swapna

  • swapna0707swapna0707 Posts: 35

    Hi @Bogdan Czwartkowski ,

    I have deployed calculator wsdl in PARASOFT Virtualize successfully,But i am getting the below error message while calling the deployed endpoint?
    Wsdl :http://soaptest.parasoft.com/calculator-02.wsdl
    http://localhost:9080/glue/calculator/add/2/

    error message:

    Could not find a valid Message Responder to respond to this request.
    Be sure you have a Message Responder with correlation criteria that match this message.
    1 virtual asset attempted to process this request:
    Sample
    add
    Correlation type: Transport
    [criteria=SOAPAction, expected=add, actual=[NOT_FOUND], results=false]
    divide
    Correlation type: Transport
    [criteria=SOAPAction, expected=divide, actual=[NOT_FOUND], results=false]
    Fault
    Correlation type: Transport
    Disabled : true
    Correlation type: Request Body
    Empty Payload : false
    multiply
    Correlation type: Transport
    [criteria=SOAPAction, expected=multiply, actual=[NOT_FOUND], results=false]
    subtract
    Correlation type: Transport
    [criteria=SOAPAction, expected=subtract, actual=[NOT_FOUND], results=false]
    subtract2
    Correlation type: Transport
    [criteria=SOAPAction, expected=subtract2, actual=[NOT_FOUND], results=false]

    Request :
    .
    Can you Please help me on this

    Thanks,
    swapna

  • Thomas MooreThomas Moore Posts: 56 admin

    Hi Swapna,

    Without being able to see what's going on, it sounds like you're sending in a blank and/or a GET request into the virtual asset. By default, the calculator wsdl that you used requires a specific SOAP request to send a valid response.

    If you have SOAtest or some other API testing solution, I would recommend trying to creating a test from the same wsdl and changing the endpoint so that it points at the virtual asset instead, or creating a custom virtual asset that has a fixed response.

    Hope this helps!

  • benken_parasoftbenken_parasoft Posts: 399 ✭✭✭

    That last question is a duplicate of this one which was already answered: could-not-find-a-valid-message-responder-to-respond-to-this-request

Sign In or Register to comment.