ERROR: Cannot launch process: Access is denied.

Andrey MadanAndrey Madan Posts: 189 ✭✭✭

When you ran C++ Desktop you need to make sure C++Test you can execute your compiler. If you don't set it up properly, you will see a message like that:

Error during process execution: Cannot launch process: "C:\gcc" "-IC:\Apps\Parasoft\C++test\10.3\engine\runtime\include" -I. -DPARASOFT_CPPTEST -v -E -dM -ffreestanding -xc "C:\Users\ANDREY~1.MAD\AppData\Local\Temp\ParaSoft.25452.41.c" -o "C:\Users\ANDREY~1.MAD\AppData\Local\Temp\ParaSoft.25452.18467.c"
Access is denied.

The problem here is that C:\gcc does not exist. But where would I change that? The answer is in the Parasoft Project Settings:
Right Click on the project and go to Parasoft->C++Test->Build Settings

Then, you will see that you need to browse to your compiler or if compiler executable is on the PATH simply specify the executable:

Problem fixed.

Comments

  • Thanks Andrey, great post!

    Just an extra note for working with Cygwin environment:

    In Cygwin 'gcc' and 'g++' can be a UNIX-style symbolic links that point to actual compiler .exe files. For example, in my system 'g++' points (indirectly) to 'g++-4.exe' located in Cygwin's '/bin' which is C:/cygwin/bin folder on Windows.

    However, C++test has to use regular Windows process API to run compiler. Windows will not understand UNIX-style sym-links that Cygwin uses. Therefore, when working with Cygwin, you should use actual .exe name of the compiler in Build Settings.
    This would be, for example, 'gcc-4.exe' and 'g++-4.exe' assuming c:/cygwin/bin is part of PATH, or full path like 'c:/cygwin/bin/gcc-4.exe'.

    Of course everything that Andrey wrote still applies.

Sign In or Register to comment.