Chrome infobar blocking playback, can we close it automatically?

LeoNLLeoNL Posts: 7

Hi,
We're using SOAtest 9.10.8 for a while now, combined with Chrome for web testing (v90 currently).
Lately (probably since chrome v84+) we encounter problems during browser playback, on some systems...
This is caused by the Chrome infobar, displaying something like: "Chrome is being controlled by automated test software".
On certain systems, when this infobar is shown, it blocks specific Type and Click actions, as if the 'focus' is retracted from the browser. Once we close this infobar, playback works fine again.

Anyone familiar with this behaviour and, even more interesting for us, did you came with a solution for this? :smile:
We tried the "user action special characters", to give it a Shift-Tab and Space/Enter, the latter doesn't work...
We also used an AutoIT script in .exe through Extended Tool, helpful for some of us, but this obviously does not work on non-Windows machines and some VirusScan apps don't like it as well.
Other thing we tried is to startup Chrome with parameters such as "--disable-extensions", this didn't help either...
Downgrading Chrome is also not an option.
So we are running out of options here :neutral:

Any ideas?

Comments

  • tonytony Posts: 24 ✭✭

    Typically this is managed by configuring the ChromeOptions as follows:

    ChromeOptions options = new ChromeOptions(); 
    options.setExperimentalOption("excludeSwitches", new String[]{"enable-automation"}); 
    WebDriver driver = new ChromeDriver(options);
    

    Unfortunately, users cannot currently configure these options from inside SOAtest.

  • benken_parasoftbenken_parasoft Posts: 1,023 ✭✭✭
    edited October 12

    SOAtest 2021.2 has been released. The "Chrome is being controlled by automated test software" info bar is not disabled by default but you can now disable it by setting the system property "webtool.browsercontroller.webdriver.thirdparty.strategy.ChromePropertyOptions.EXCLUDE_ENABLE_AUTOMATION" to true like this:

    soatest.exe -J-Dwebtool.browsercontroller.webdriver.thirdparty.strategy.ChromePropertyOptions.EXCLUDE_ENABLE_AUTOMATION=true
    
Sign In or Register to comment.