Compatibility of SOAtest/Virtualize coexistence for 2020.1 and 2020.2

dwhitehousedwhitehouse Posts: 5

2020.2 was installed before learning about the requirement for a new product password. I understand that the workspace has changed. Except for those services or functions that are deprecated, can I continue to use the 2020.1 version in the same workspace until Parasoft provides the requisite password update? Otherwise, I am stuck between the past and present.

Best Answer

  • benken_parasoftbenken_parasoft Posts: 1,018 ✭✭✭
    Accepted Answer

    Are you referring to the "Older Workspace Version" dialog? The one that says something like "Workspace was written with an older version ... Updating the workspace can make it incompatible"?

    This has to do with SOAtest 2020.2 including Eclipse 4.16 (2020-06) and the previous release using Eclispe 4.6 (Neon). Certain Eclipse plugins may save information in the workspace differently so that once the settings are updated they may not be readable if you were to re-open the workspace in an older version of Eclipse. So, I generally wouldn't recommend opening the same workspace back and forth between two different releases of Eclipse. So, if you need to use SOAtest 2020.1 then, to be safe, I would not open the workspace in SOAtest 2020.2 until you are ready to switch. Any test assets (.tst files) saved or re-saved in 2020.2 may also not open anymore in SOAtest 2020.1.

Answers

  • dwhitehousedwhitehouse Posts: 5

    Thank you. We had previously moved on to Eclipse 4.16 after checking with support. If my understanding of you explanation is accurate, then there should not be any problems. Hopefully Parasoft will respond shortly with updated passwords.

Sign In or Register to comment.