Testsuite Execution Options were not working for the setup

ParasofttoudayaParasofttoudaya Posts: 232 ✭✭
edited August 2018 in SOAtest

Hi Team,

We are having complex level validations, where we wanted to use the execution options extensively. In this case "Tests run as group" is not working as expected or we are looking for the options to be used.

As shown in above image, validateResponse Test suite gets input from writable-data-source which is extracted from the GetResponse's databank.

DeciderOne gets inputs from the writable data-source which branches to "BranchOne" or "BranchTwo" and both branches supposed to be loop from the same data source.

In this case, "Tests run as group" is not working.

we changed to "Tests run all sub-groups as part of this group" and it worked fine.

But when we have the same kind of branching below as nested, we are facing the problem. Looping is not happening as all the nested test suites are set to "Tests run all sub-groups as part of this group".

Let me know what can be used when this kind of branching is required to make decision of branching.

Note : When there is no branching its working fine.


  • benken_parasoftbenken_parasoft Posts: 809 ✭✭✭
    edited August 2018

    It is difficult to say what's going on without having more detail. If I understand you correctly, GetResponse writes to the writable and DeciderOne is iterating over the writable. In this is true then if you were to use "Tests run as group" then BranchOne/BranchTwo would iterate over the writable as well, since they are now iterating over the writable data source as a group instead using their own data sources individually.

    When you say "BranchOne" or "BranchTwo" is "supposed to be loop from the same data source" do you mean the writable or some other data source? This is very important for someone to understand the behavior but I can't tell based on the screenshot and description. Data source iteration behavior can change in various ways when there are multiple data sources in play as opposed to a single data source.

    Lastly, when you say that "Tests run as group" is not working can you be more specific, indicating what you see happening? Does "BranchOne" or "BranchTwo" run once or not all or too many times or something else? The more specific the better.

    For a timely resolution, I'd highly recommend you consider contacting Parasoft Support. The answer to this seems very specific your particular test suite and how you have things configured, something support could possibly look at with you over a call or streaming session.

  • ParasofttoudayaParasofttoudaya Posts: 232 ✭✭
    edited September 2018

    Thanks @benken_parasoft
    created a ticket and solved the issue.
    Setting "Multiple Data Source Iteration" to "Flat (lockstep)" solved the issue :)

    Note: This option exist only at the root level default test suite.

    Thanks a ton to @Ramiro Martinez :smiley:

Sign In or Register to comment.