Command line to "Start Soatest Server" fails

reactancexlreactancexl Posts: 139

The server starts but after it starts i keep getting ( There are no deployments on this server. Cannot respond to this request:). It is a brand new installation. I tried using the gui to create the workspace and command line to create workspace. Here is my syntax
soatestcli.exe -startServer -localsettings "" -data "C:\SOATestServer\Workspace"



  • OmarROmarR Posts: 224 admin

    Good morning,

    Based on the server message, it appears that the server started successfully, but there are no deployments on the server. Please take in mind that .tst files are not considered deployments. Server deployments are virtual assets (Virtualize) that can be configured to send messages correlated to request messages in order to simulate back-end services. If you wish to do this, I recommend taking a look at Parasoft Virtualize.

    If you wish to run .tst files through CLI, you will need to add the -config argument to your command in order to specify the execution configuration.

    Do you plan on executing your .tst files through CTP? If so, you should be able to see your .tst files under CTP>API testing after server startup.

  • reactancexlreactancexl Posts: 139

    I have a soatest server and virtualize server license to run on two separate VM's. The virtualize server is working connecting to CTP. The soatest is using command Line. When I use the soatest gui, I am able to connect to CTP and CTP shows that. I export the prop file to get the connections etc. When I run command line it keeps giving me no deployments and no connection to CTP. Permissions are not an issue as I gave account admin rights.

  • benken_parasoftbenken_parasoft Posts: 890 ✭✭✭
    edited June 2018

    If you have a SOAtest-only installation and try navigating to the server URL in your web browser then you will see the message "There are no deployments on this server. Cannot respond to this request". Other clients, such as CTP, may also query the server to check for deployed assets in which case this message may also be returned.

    This message is is informative (not an error), letting you know there are no virtual assets deployed. Of course, this would be the case if your SOAtest installation doesn't include Virtualize or if you never deployed virtual assets. If your installation contained Virtualize and had virtual assets deployed then you would see a different message listing the deployed virtual assets.

    In short, this message means that your SOAtest Server is running and behaving properly. :) If you want to access something meaningful from your web browser, then you can access the API docs from http://yoursoatesthost:9080/soavirt/api

Sign In or Register to comment.