Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

Unable to Access Adobe Document in Browser Application

Speedy993 Posts: 51

I am running a Selenic Junit test that is trying to insert a string in a text box in an Adobe eSign document. This is opened inside of a Java application running in Microsoft Edge. I then want to click a button also in the document to continue processing in the Java app. The problem is Selenium says there is no such element or it is not clickable, depending on whether I try to clear it or send a CONTROL + "a" and then DELETE before sending the text.
A little more information, I am able to log into Adobe Acrobat in the test before I get to the point of trying to access the document. Using the Inspect ability in the browser I get the xpath of '//[@id="document"]/ul/li/div[2]/input' and the full xpath of '/html/body/div[2]/div[2]/div/div[3]/ul/li/div[2]/input'. So it appears that the field in the document is visible to the browser. I have tried both definitions for the WebElement:
@FindBy(xpath = "//
private WebElement adobeAcrobatDocSignLine;

@FindBy(xpath = "/html/body/div[2]/div[2]/div/div[3]/ul/li/div[2]/input")
private WebElement adobeAcrobatDocSignLine;

The set function has been tried a couple of ways:
public void setAdobeAcrobatDocSignLine (String text) {
// waitFor(adobeAcrobatDocSignLine).clear();
adobeAcrobatDocSignLine.sendKeys(Keys.CONTROL + "a");
using the clear function and then sending the text and sending the ctrl a and delete before sending the text.

Is there something wrong with my code or is this an issue because of the Adobe document or there something more to it?

Any suggestions?



  • benken_parasoft
    benken_parasoft Posts: 1,205 ✭✭✭

    In case this helps you, I see a number of posts on using "selenium" and "docusign" on stackoverflow:

    For example, the result for "cannot click on docusign document" describes something similar which turned to be a missing call to switch to the iframe containing the docusign page.

  • Speedy993
    Speedy993 Posts: 51

    Thanks benken_parasoft!
    Just getting back to this issue. I am not sure if these will work or not as I don't think our framework is using frames. I need to talk to the developer of the application to see what he thinks as well. I will respond back when I get this to work.