Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

Chrome does not allow this extension to change proxy settings.

I work in an env where browser configuration policy is managed by the company. I get the error shown in the title when I try to enable API Traffic for Parasoft SOAtest. It prevents me from being able to record. I tried the following workaround but it did not work. Is there another way around this?

I confirmed that my local SOAtest server was running. I entered the requested information in the Parasoft Recorder extension configuration screen. I tested the connection, and everything lit up green. I then went to Windows "Internet Options" and changed the proxy settings to point to the Parasoft recording proxy. After that, when I test the connection the extension fails to connect to SOAtest.

I do not believe my company will change the policy that is preventing Chrome from changing proxy settings. Is there a manual way to do this that will work? Thanks, JT