Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

How to setup the Catch-All SOAP option to be a pass through?

I have a responder that has Multiple Responses selected and it is currently working fine when it finds a match to the text of an element.

However I need to be able to configure the responder to pass any unmatch requests through to the actual end point.

Any thoughts???


  • williammccusker
    williammccusker Posts: 618 ✭✭✭


    I think what you are looking for is provided by a Message Proxy

    The Message Proxy has options for falling back to a live service if a call fails. In this case, it would be a Message Proxy in front of the Virtual Asset so that when the responder fails to find a match the Message Proxy would then call the actual endpoint.

    Hope this helps!

  • TScheafer
    TScheafer Posts: 15

    I have read through that and I just can't seem to get it to work. I am attaching some screen prints, maybe that will help.

    I can set the outgoing message proxy directly to the live service and it works but all tests go there.
    I can set the outgoing message proxy to the localhost and it works but all test go there.

    The error I get is: "None of the multiple responses correlation conditions matched the request.", which is what I was expecting but I would like for it to route that call to the live site.

  • williammccusker
    williammccusker Posts: 618 ✭✭✭


    I think what is happening is that the Responder defaults to sending back an HTTP 200 response even though none of the multiple response conditions matched. I think if you add another Message at the end of your existing Multiple Responses with no matching conditions enabled and in the "Response Options" set the HTTP status code to 404 or 500 then the message proxy should get that message and failover to the live service.