Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

How to solve the error: "Invalid compiler config file"

shjalilian
shjalilian Posts: 5

Hi
I am using Flow Analysis Standard in parasoft 10. My c project has been compiled in keil without any error and I imported it to parasoft using uvision keil project file. Then I run the Flow Analysis Standard but it issued this error "Invalid compiler config file" for all source files. Two tipical error messages are as bellow:

1. ERROR: Invalid compiler config file: C:\Program Files\Parasoft\C++test\10.4\engine\etc\compilers\rvct_4_0_uV\cpp.psrc

[ERROR] Code Analysis for GBC/BusDrivers/SRI_Wdt.c finished with code 1 (other)
1. ERROR: Invalid compiler config file: C:\Program Files\Parasoft\C++test\10.4\engine\etc\compilers\rvct_4_0_uV\cpp.psrc
[ERROR] Code Analysis for GTBC/EquipmentHandler/TestTask.c finished with code 1 (other)

Has everyone faced with this problem?
It is appreciated to share your experiences

Answers

  • shjalilian
    shjalilian Posts: 5

    I resolved this problem. Although I have imported the keil project file into Parasoft, but the compiler gcc was set for it instead of armcc. Then I set it manually and the error removed.

  • simon2k
    simon2k Posts: 3
    edited June 1

    Hi shjalilian,
    I 've got the same issue in my pipeline here!
    Where did you set the compiler manually?

    I 've imported multiple projects to my Workspace and after running the unittests, it drops multiple lines!
    One with

    "valid compiler config file: /gcc_7_3_poky/cpp.psrc"

    and multiple with

    "invalid compiler config file: /gcc_7_3_poky/cpp.psrc"

    Don't know why. Hope someone could help me out!

    Greetings,
    Simon

  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 148 admin

    Hi @simon2k ,

    How do you set custom compilers location? Is it in local settings file? Can you share how are you running C/C++test CLI, and what are the exact compiler settings there?

  • simon2k
    simon2k Posts: 3

    Hi Bogdan,
    we have had no compiler settings in the localsettings.properties. I'd thought the cpptestrace call to generate the bdf before importing project to workspace would detect it right.
    Now I defined the compiler family in localsettings, so so the error is gone.

  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 148 admin

    Hi @simon2k ,

    Many thanks for the update. I am happy you got it to work.

    The auto detection of a compiler is working in many cases. However, it is a heuristic based on how a compiler program is named and how it presents itself with version and other outputs. With GNU GCC-based compilers where there are many clones, like the Poky build here, the cross-compiler was apparently not recognized, hence C/C++test needed some help by setting the compiler in local settings.

    Again, thank you.