Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

virtualize response

jimboy
jimboy Posts: 33

I copied a response message and the message does not come with the tag soap envelope and soap body. I literally change this to form input so I have the flexibility of add and removing elements. When I send the response to the system. The system would not understand the soap envelop and soap body where the response messages are in. Is it possibly on the form input response to take out the soap envelop, soap body before sending the response back to the system?

Comments

  • benken_parasoft
    benken_parasoft Posts: 1,089 ✭✭✭

    If you are wanting to send plain XML and not a SOAP envelope then you need to be using a "Plain XML Message Responder" instead of a "SOAP Message Responder". They are actually the same responder except for what's selected by default on the "Definition" tab. On this tab you want to make sure "Service definition" is set to "Schema" and that "XML Message Type" is set to "Plain XML".

  • jimboy
    jimboy Posts: 33

    thanks, it works

  • jimboy
    jimboy Posts: 33

    changing it to plain XML responder where the form is structured as form XML somehow causing not to pull the script from data source. I have tried to use log.info to show the scripts information but that does not seem to work on virtualize. I have compared the script between the form input(soap message responder) and form XML(plain XML responder).

  • jimboy
    jimboy Posts: 33
    edited June 2021

    It works if I change it back to form input(plain XML responder). I do need to keep the input mode as form XML so I can enable and disable some elements. I wonder what is causing the script not to pull from the datasource.

  • benken_parasoft
    benken_parasoft Posts: 1,089 ✭✭✭

    The responder can pull values from data source columns if your responder has data source correlation configured.

    If you are executing a script somewhere that needs to read values from a data source then make sure you also selected the "Use data source" checkbox above the Language selector.