Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

VS 2017 help

SharonLevy Posts: 7


I am using VS2017 and installed Parasoft C++ test v10.4.2 and after installation the Parasoft still doesn't appear in the menu/

What can be the reason for that issue?



  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 142 admin

    Hello @SharonLevy ,

    The most common reason for such issue is missing workloads in Visual Studio. See here for details:

    Basically, you need to make sure that both Universal Windows Platform and C++ development workloads are installed for C/C++test plugin to work.

  • SharonLevy
    SharonLevy Posts: 7

    Hello @Bogdan Czwartkowski
    hi have already check those configuration, they are already defined and still the Parasoft doesn't appears in the menu
    see attached images

  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 142 admin

    Hi @SharonLevy ,

    I can think of many possible reasons and things to check now. The issue seems related to specifics of this particular environment or installation. Therefore, at this point I would recommend to contact our support team to look closer into the issue.

    You can contact us either through the Parasoft Customer Portal or by writing to [email protected]

    See here for details: https://www.parasoft.com/support/

  • SharonLevy
    SharonLevy Posts: 7

    Hi @Bogdan Czwartkowski
    i manage to somehow activate the Parasoft in the VS2017.
    But, once i run the static analysis (user defined), no file is being analized.
    Scope is update with the currect list of files bit the list of files checkd is 0/0
    what ca be the issue?


  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 142 admin

    Hi @SharonLevy,

    I would need to have a look at the complete and verbose Console Tab output from C/C++test run to see if I can tell what is going on or at least narrow down on the possibilities.
    Can you do the following:
    1. Verify that C/C++test is functioning correctly on one of example projects shipped with the product.
    2. Go to Parasoft menu> Preferences> Parasoft> Console and set verbosity level to "High".
    3. Launch your analysis again on your project, and attach full console output here.

    In case the output contains sensitive content, you can contact suport team instead of using forum.

  • SharonLevy
    SharonLevy Posts: 7

    Hi @Bogdan Czwartkowski ,
    I configure as yiou described, both in the example projects (ATM/Shapes) no static analysis is performed.
    in the output window there is nothing written for "C/C++test" output.

  • Bogdan Czwartkowski
    Bogdan Czwartkowski Posts: 142 admin

    Hi @SharonLevy ,

    Again, i strongly recommend to contact our support. This sounds like either configuration or installation issue which prevents C/C++test to work, but first: I cannot be sure with so limited information, and second: there is myriad of possibilities to check now, so working with our support team is the most efficient scenario.

  • SharonLevy
    SharonLevy Posts: 7

    Hi @Bogdan Czwartkowski ,

    i am trying another appoach, to run the analysis vai command line and i receive the following exception:
    Parasoft C/C++test Professional -- Copyright (C) 2019 Parasoft Corporation
    Parasoft Test -- Copyright (C) 2010-2019 Parasoft Corporation

    WARNING: Could not connect to the selected Team Server.
    A local cache will be used in read-only mode from now on.
    INFO: No resources specified as scope, using all workspace projects as selected scope.
    *** exception in native code ***
    System.NullReferenceException: Object reference not set to an instance of an object.
    at IKVM.Runtime.JNIEnv.SetObjectArrayElement(JNIEnv* pEnv, IntPtr array, Int32 index, IntPtr val)
    at com.parasoft.xtest.common.nativecode.NativeEnvironment.environment()

    Sharon Levy

  • Hello @SharonLevy ,

    It seems there is something wrong locale settings in the environment. Can you try the following diagnostic steps and paste here the outcomes:
    1. Run Control Panel> Region> Administrative Tab> press Copy Settings button, and take screenshot of displayed settings.
    2. Launch command prompt, run "chcp" command, and collect the output.
    3. Ideally, if you could also create C# solution, run the following program and collect the output, as the result may be different than with "chcp":

    using System;
    namespace CodePageCheck {
        class Program {
            static void Main(string[] args) {
                Console.WriteLine("OEMCodePage: " + System.Globalization.CultureInfo.CurrentCulture.TextInfo.OEMCodePage);   

    Finally, you may want to try the following. It does not always help, but it is worth a shot even for diagnostic purposes:
    1. Launch "Developer Command Prompt for VS2017"
    2. Run the following command to change code page: CHCP 437
    3. Launch VS2017 IDE from the same command prompt by running "devenv.exe"

  • GavinWhatley
    GavinWhatley Posts: 1

    Is there a solution to this problem? I am using VS2019 with Parasoft C/C++ Plugin 10.5. VS2019 is very inconsistent at loading the extension.