Undefined Reference to CPP Test Functions

george199george199 Posts: 2

Hi,
Im running into an issue with CPP Test, it seems that whatever i try when running unit testing i get 'Undefined Reference to cpptestTestSuiteBegin and an array of others, ive checked all the settings against the install guide and it seems to be correct.

Im running Parasoft C/C++test Professional - Version: 10.4.3.20191114B689, with Gnu C compiler on windows 64 bit system.

Static Analysis runs as expected.

Any thoughts how i could fix this?

Many thanks,
Chris

Comments

  • Bogdan CzwartkowskiBogdan Czwartkowski Posts: 114 admin

    Hello @george199 ,

    You may want to check if the compiler is configured correctly in the build settings of the C/C++test project. You can verify that by right-click on your project node in C/C++test GUI, then go to Properties> Parasoft> C++test> Build Settings> Compiler.
    Once there, please, verify that compiler family combo box matches your compiler version, and - which is important for unit testing - if it matches "bitness" of your compiler.

    The compiler version should be selected closest to the GNU GCC version you are using. Note, that there are separate compiler configurations for 32- and 64-bit compilers, so make sure to select the correct one.

    Example:
    If you use GNU GCC 7.4 64-bit compiler, you would need to select
    "GNU GCC 7.x (x86-64)", but not "GNU GCC 7.x" which is meant for 32-bit compilers.

    I hope this helps.

  • george199george199 Posts: 2

    @Bogdan Czwartkowski - You hero, thats got rid of the CPP TEST reference errors, some symbol errors to sort now (local to application) and we should be good to go.

    Thank you so much!

  • Bogdan CzwartkowskiBogdan Czwartkowski Posts: 114 admin

    @george199,
    Many thanks for the update! I am glad I could help :smile:

Sign In or Register to comment.