Submit and vote on feature ideas.

Welcome to the new Parasoft forums! We hope you will enjoy the site and try out some of the new features, like sharing an idea you may have for one of our products or following a category.

ANT Soatest default path

Options
Ankob1985
Ankob1985 Posts: 14

Hi,
I am still working on a fix for a project .We use ANT scripting to start Soatest. Jenkins is used to start the run. The testcase can be found and is started.
After that the first thing it needs to do is look up for a WSDL that is located in the basedir.
The WSDL can't be found.
After adding de workspace_Loc global, i was able to determine the location where it is searching for the file: file:/tmp/parasoft.workspace\Regressieset\WSDL\Schemas\CreateMeteringPoint_2p1\CreateMeteringPoint_2.wsdl. Make sure that the document exists and that it is a WSDL Document.

This is quite a different location then where the files are situated. Can someone help me how i can change the default location of the workspace?

Best regards,
Anko Bouwer

Comments

  • jakubiak
    jakubiak Posts: 804 admin
    Options

    Is it possible to include a screenshot of the UI where the WSDL is specified, so we can see how it is configured?

  • Ankob1985
    Ankob1985 Posts: 14
    edited December 2019
    Options

    hi Jakubiak, i already found a solution. I saw that the .parasoft file for de EXCEL files uses a global named: ${test_suite_loc} in my case.
    From that point on it runs with the correct files and can find the WSDL.

    But now the next failure, Received fatal alert: protocol_version. We run with 9.9 and localy with give a java_home for Java8 to the prompt.
    Is this possible for linux? to fix this? upgrading is also an solution to 9.10. But is there a way to stay on 9.9 and fix this error?

  • jakubiak
    jakubiak Posts: 804 admin
    Options

    If you google "Received fatal alert: protocol_version" you will find posts that seem to describe the problem. It looks like you need to pass a system property to control which TLS version gets used. You can do this for soatestcli like this:
    -J-Dhttps.protocols=<version>

  • benken_parasoft
    benken_parasoft Posts: 1,243 ✭✭✭
    edited December 2019
    Options

    We run with 9.9 and localy with give a java_home for Java8 to the prompt.

    Make sure you are doing this using "-Zjava_home" as in something like:
    soatestcli -Zjava_home {path_to_java_8}

    If you are correctly using Java 8, then TLSv1, TLSv1.1, and TLSv1.2 are enabled by default. In Java 7, only TLSv1 is enabled by default. So, if you need TLSv1.1 or TLSv1.2 then please make sure you are really set the "-Zjava_home" variable correctly. If set correctly, soatestcli should print a message, indicating the a custom java version is being used.

    If you need to restrict to a specific protocol or TLS version, you set a "jdk.tls.client.protocols" property as described here:
    https://docs.oracle.com/javase/8/docs/technotes/guides/security/jsse/JSSERefGuide.html#InstallationAndCustomization

    "jdk.tls.client.protocols" is available in Java 8. It was also added to Java 7 but not in the particular version of Java 7 that is included with SOAtest 9.9. You do not want to set "https.protocols" as this does not apply to all SSL sockets including those created by SOAtest.

    Unlike Java 7, SSLv3 is no longer enabled by default in Java 8.
    So, if you need SSLv3, you have to edit the JRE_HOME/lib/security/java.security file as described here:
    https://docs.oracle.com/javase/8/docs/technotes/guides/security/SunProviders.html#enable-sslv3