cpptestcli error:unable to find parasoft test installation

fatmanur61fatmanur61 Posts: 70

When I want to work command line and try to run static analysis in command line take cpptestcli error:unable to find parasoft test installation error. Related image is added to question.

Answers

  • MichaelCMichaelC Posts: 28 admin
    edited May 21

    Hello @fatmanur61, the error that you're seeing is either caused by some of the following scenarios:
    1. C++test 10.4.2 wasn't properly installation
    2. The location of Parasoft Test directory was moved after installation and .pathtoparasofttest was not updated.

    Solutions to these scenarios:
    1. (Recommended) Re-install C++test to resolve this issue.
    2. Open .pathtoparasofttest with any text editor and change the path to point to your new Parasoft Test Directory. The .pathtoparasofttest file can be found within the C++test home directory.

    The .pathtoparasofttest file is hidden by default you will need to go to View at the top left of your File Explorer view and check "Hidden Items" to show the file

    I would also recommend using C++test 10.4.2 Standard Edition if you're planning to run static analysis from the command line. C++test Standard is a light-weight engine version of C++test that is designed for command line automation and CI integration such as Jenkins.

    A copy of the C++test standard installation folder can be found within C++test 10.4.2 home directory. It's stored under the zip file parasoft_cpptest_standard-{VERSION}-win32.x86_64.zip. Copy the zip file to a secure location and extract the file. To license C++test Standard Edition you will need to go within the C++test Standard Directory and modified the cpptestcli.properties file to match your local license or your network license configuration.

    I have attached a few links to some documentation that will help you get started with C++test Standard Edition:

    C++test Standard setting up Automation License:
    https://docs.parasoft.com/display/CPPTEST1042/Setting+the+License

    C++test Standard Running Static Analysis:
    https://docs.parasoft.com/display/CPPTEST1042/Running+Static+Analysis+1

  • fatmanur61fatmanur61 Posts: 70

    @MichaelC thanks for your answer. I download the marked C++test setup files (standalone and standard editions) in attached image. I will install them again tomorrow and I will do your weigh your words.

  • fatmanur61fatmanur61 Posts: 70

    Hi @MichaelC thanks for your support I solved the problem. And I want to ask you one question. How can I create bdf file with using msvc compiler using command line? This project normally is working Microsoft VS 2010.

  • MichaelCMichaelC Posts: 28 admin

    @fatmanur61,

    You can generate a bdf using a Visual Studio compiler by adding cpptesttrace in front of your visual studio command line build.
    cpptesttrace %CPPTESTTRACE_OPTIONS% %COMPILER% %COMPILER_OPTIONS%

    Original Build Command:
    nmake /nologo /S /F Examples.mak clean all MS_VER="VC10" CPU="x86"

    Updated Build Command with Cpptesttrace options:
    cpptesttrace.exe --cpptesttraceOutputFile=D:\cpptesttrace.bdf --cpptesttraceTraceLog=D:\testLog.log --cpptesttraceProjectName=Examples nmake /nologo /S /F Examples.mak clean all MS_VER="VC19" CPU="x86"

    I used nmake as an example build system but you can use cpptesttrace on the compiler such

    cpptesttrace.exe %CPPTESTTRACE_OPTIONS% cl.exe %VS_COMPILER_OPTIONS%

    I have attached some documentation that goes into more detail about generating a bdf below.

    Generating a Build Data File:
    https://docs.parasoft.com/display/CPPDESKE1042/Creating+a+Project+Using+an+Existing+Build+System

  • fatmanur61fatmanur61 Posts: 70
    edited May 23

    Hi @MichaelC,

    I looked your answer. Thank you for your answer. We can easily take successful build in vs 2012 ide for our example but when we want to get build in command line we get the attached error. Do you have any idea for this error? Could you help me?

  • MichaelCMichaelC Posts: 28 admin

    @fatmanur61 your current command prompt isn't configured to build Visual Studio projects via command line. I would recommend using the Developer Command Prompt for VS 2017 as the environment is already set up to build and execute Visual Studio projects.

    Example of normal nmake build:

    Modified nmake build:

  • fatmanur61fatmanur61 Posts: 70

    Hi @MichaelC ,

    Thanks for your support. We solved the problem but we encountered another problem :) We prepare a .bat file and we call this bat file from jenkins. This bat file commands works in Visual Studio command prompt. When I execute these commands individually There have no problem but when I call bat file from normal command prompt We take the "-vs switch has to be specified with Visual Studio version " problem. Related images added to issue.

  • MichaelCMichaelC Posts: 28 admin

    Hi @fatmanur61,

    Can you create a new discussion for this issue?

  • fatmanur61fatmanur61 Posts: 70

    Hi @MichaelC. Okey I will create new issue for this problem.

Sign In or Register to comment.