DS-5 Unit Test Execution

fatmanur61fatmanur61 Posts: 70

I am working with Arm DS-5. I use Eclipse IDE for Arm DS-5 I use Arm C Compiler 5 and I use cortex A9. I easily generate unit test via generate unit test feature of Parasoft. I can reach generated test from Test case explorer. But I can not run these test. When I run the tests, the console part of IDE does not affect. Therefore after "Build Test Executable" the executed test number is 0. How can I execute autogenerated unit tests via DS-5?

Related images about problem added to this discussion.!

Tagged:

Comments

  • MirekMirek ✭✭ Posts: 102 ✭✭

    Hi @fatmanur61,

    "Build Test Executable" test configuration will only prepare a test binary without executing them. If you want to execute created unit tests you need to use the config "Builtin>Embedded Systems> Run DS-5 Test Executable (FVP simulator). Note that execution tab may require your configuration (details related to simulator setup)

  • fatmanur61fatmanur61 Posts: 70

    Hi @Mirek,

    Thanks for your answer. I try to run my autogenerated test cases via Rum DS-5 test executable (FVP simulator) but again I obtained zero executed test. Do you think this vade occurs when the lisence does not support Embedded support feature? That is at the lisence tab menu in parasoft tab of tool bar menu of ds5 the embedded support future seems like N/A mode and its color is Grey.

  • MirekMirek ✭✭ Posts: 102 ✭✭

    Hi @fatmanur61,

    Please increase the console verbosity to high, re-run the test configuration and provide information about the messages reported in the console window.

  • fatmanur61fatmanur61 Posts: 70
    edited March 5

    Hi @Mirek,

    How can I increase the console verbosity? How can do it in ide? When I execute run ds5 test executable (FVP simulator ), I noticed the case which is described in the attached image.
    Therefore after tests executed, the number of executed test is 0.

    This situation occurs when lisence is not valid for this test execution feature isn't it?

  • fatmanur61fatmanur61 Posts: 70

    @Mirek I added the image which is decribe lisence case. Image name is DSC_0090

  • Bogdan CzwartkowskiBogdan Czwartkowski admin Posts: 93 admin

    Hi @fatmanur61,

    I think this is the same topic we already discussed by email.
    As the message indicates, in order to run tests on the target you will need the "Embedded Support" license feature.
    Also, as I see from the console output, you have enabled option to publish results to DTP, however your license does not include "DTP Publish" feature.

  • fatmanur61fatmanur61 Posts: 70

    Hi @Bogdan Czwartkowski yes you are right. I have worked with texas instruments code composer and run test for code composer ide and I take the same result. This embedded support is necessary for all environment. The features which are diccuss by us should be enable.

Sign In or Register to comment.