[Embedded Server] Issue when creating PVA from recorded traffic

WagnerWagner Posts: 9

I'm running SOATest & Virtualize, 9.10.3 locally on Windows 10.
I tried creating a PVA from a recorded traffic file, and i get the following error,

com.orienttechnologies.comon.io.OIOException. Cannot connect to any configured remote nodes 127.0.0.1:9100

I'm running the embedded server on my local machine. Are there any special configuration settings that could explain this? This works on a colleagues machine, but not my own.

See attached file

Comments

  • VirtualUserVirtualUser Posts: 8

    hi, it seems like the embedded repository server did not start successfully. You may check this by looking in the Data Repositories view, the icon for the [Embedded Server] is likely gray (not active) rather than sky blue (active).

    Have you tried restarting the product? It would help to know if the embedded server not starting was an isolated occurrence or if it persists on your machine.

  • WagnerWagner Posts: 9

    Hey there!

    Thanks you! In the Data Repositories view, the icon for [Embedded Server] shows grey, each time i start up the application.

    I've tried restarting several times, and running as administrator, and the problem still persists, unfortunately.

  • keegan_chankeegan_chan Posts: 47

    Do you have data in the Embedded Server that you need to keep?

  • WagnerWagner Posts: 9

    I do not have any data that I need to keep in the Embedded Server. This is my first attempt since installation to use it.

  • WagnerWagner Posts: 9

    More Information:
    Upon startup, my console shows the following message:
    Failed to start Data Repository server Failed to locate data repository shutdown script.

    Also, I found it's using to be using port 9100 from the following message in Window>Preferences>Parasoft>Server:
    Currently running on port 9100 (automatically set based on port availability)

  • VirtualUserVirtualUser Posts: 8

    hi, you may want to try to stand up your own data repository server over which you can have full control to start up and stop. Pretty easy to set up, described here:
    https://docs.parasoft.com/display/SOAVIRT9103/Installing+a+Remote+Data+Repository+Server

  • benken_parasoftbenken_parasoft Posts: 589 ✭✭✭
    edited August 2018

    Failed to start Data Repository server Failed to locate data repository shutdown script.

    First, I would verify there are no old data repository server instances already running, looking for any "java" processes in the background (Task Manager or "ps" command, for example). Then, I would close SOA/Virt then manually delete the "DataRepository" folder from the .metadata folder under the workspace directory (might be something like "C:\Users\username\parasoft\soavirt_workspace.metadata\DataRepository"). Lastly, when starting SOA/Virt again, you should see the "DataRepository" folder recreate itself and also see a second java process launch in the background for the data repository server, if it was able to start.

  • WagnerWagner Posts: 9

    @VirtualUser, I was able to set that up, and make the PVA that way, despite getting errors during startup. Such as,
    curl: (7) Failed to connect to port 8080: Connection refused
    Error when registering with TDM.

    @benken_parasoft I'll try that, and get back to you!

  • VirtualUserVirtualUser Posts: 8
    edited August 2018

    to not have the script attempt to connect to TDM you can comment out line 15 in server.bat
    SET TDM=http://localhost:8080
    or, if you have a TDM server, modify the line accordingly

  • WagnerWagner Posts: 9

    I tried upgrading my version of SOA/Virt to 9.10.5, and that did not seem to fix the issue, unfortunately.

    @benken_parasoft I tried what you suggested;
    Closed down SOA/Virt, see no java processes running in Task Manager.
    Naviagated file explorer to my workspace, and deleted ".metadata/DataRepository" and ".metadata/DataRepository-stage".
    Empy the Recycle bin. --They're really gone.
    Startup SOA/Virt with the same workspace.
    (Here i noticed there was no longer an error in console, as well as the Embedded Server icon appeared blue)
    Try to create the Asset.

    It works!
    Thanks!

Sign In or Register to comment.