cpptestcli -list-configs do not display my Team rules

elchelch Posts: 62
in DTP

Hi,

Running cpptestcli -list-configs do not display my Team rules.
I have license for Team , From the VS GUI I can reach and run rules.
Tried any format to point my team rules.
Added all required tcm entries to my cpptestcli.properties file.
Any suggestions ?

Thanks In Advanced,

Answers

  • Bogdan CzwartkowskiBogdan Czwartkowski Posts: 52 admin
    edited May 28

    In addition to all the regular DTP server connection details and credentials, do you have the following flag uncommended and set to "true" in your cpptestcli.properties?:

    dtp.share.enabled=true

    If that does not help,
    can you provide your cpptestcli.properties file, or better yet, can you run cpptestcli with -showsettings option and send us the output?
    If you cannot share the output, please, contact our support team.

  • elchelch Posts: 62

    Hi,

    Thanks on the follow-up

    1. When I run show-settings , the tcm entries were not displayed.
    2. dto.share.enabled=true is set.
    3. There is an issue when running -list-configs
    4. "Upgrading old Keys"
    5. "Cannot upgrade tcm.server.enabled , new key dtp.share.enabled is already present in settings."

    Thanks In Advanced,

  • Bogdan CzwartkowskiBogdan Czwartkowski Posts: 52 admin

    Hi @elch,
    I suspect there is some mix of 9.x-style options with the new 10.x options, but I do not have enough context. I would still need the -showsettings output. Looks like something specific to your setup, so I will have someone from support team contact you to process this further.

  • elchelch Posts: 62

    Hi,
    Thanks on the follow-up:
    Should I add workspace location
    cpptestcli -config-list -data "/home/user/tempworkspace"

  • elchelch Posts: 62

    of course I meant:
    cpptestcli -list-configs -data "/home/user/tempworkspace"

Sign In or Register to comment.