Ambiguous protocol URL, cannot determine tool in multi-tool mode when running soatestcli on linux se

tayloreric87tayloreric87 Posts: 3

We recently installed soatest on our linux server and we're trying to run soatestcli with a test suite created from windows. We are using a localsettings.properties file to run the configuration but we get the following error :smile:

"Ambiguous protocol URL, cannot determine tool in multi-tool mode: 0, , file:/apps/parasoft/soatest_virtualize/9.10/localsettings.properties "

We've tried using the default workspace linux creates when running the soatestcli and a workspace ported over from windows. Both give the same error. Has anyone seen this error or knows what it relates to?

Comments

  • benken_parasoftbenken_parasoft Posts: 421 ✭✭✭
    edited May 11

    You appear to be passing a bad argument to soatestcli for the -localsettings argument. It looks like you are trying to pass a path to your localsettings.properties file. The "file:" in the front of the path is wrong, resembling a malformed file URL. You should only be passing a file system path "/apps/parasoft/soatest_virtualize/9.10/localsettings.properties"

  • tayloreric87tayloreric87 Posts: 3

    Thank you for replying so quickly. We are not including the "file:/" in our argument The below is what we are calling. With your response we realized that we weren't including a "localsettings" argument. Instead we were just using config. In this case... what would we use instead of the properties reference for config?:

    soatestcli -config "localsettings.properties" -resource "/TrainingUser0"

  • benken_parasoftbenken_parasoft Posts: 421 ✭✭✭

    I haven't yet tried reproducing what you are describing but I will say that I have been running soatestcli on Linux without issue. In my case, I've been passing an absolute path to my localsettings file. Perhaps you can try that instead, just to see if that helps?

  • Thomas MooreThomas Moore Posts: 56 admin

    Hi tayloreric,

    A sample soatestcli argument for you might look like the following:

    soatestcli -config "user://Example Configuration" -localsettings "localsettings.properties" -resource "/Traininguser0"

    The -config is how SOAtest knows how to run the test, similar to clicking the run button in the SOAtest desktop.

    Hope this helps!

  • tayloreric87tayloreric87 Posts: 3

    Thank you both!! We tried specifying both -config and -localsettings and we did get past that error. :) :) . We are now running into a licensing issue for some reason even though our properties file points to a valid licensing server.

Sign In or Register to comment.