Received fatal alert: handshake_failure

ParasofttoudayaParasofttoudaya Posts: 180

Hi Team,

We are getting "Received fatal alert: handshake_failure" error, and we got a solution like updating the eclipse config file -vm argument to latest jvm "C:\Program Files\Java\jdk1.8.0_144\jre\bin\server\jvm.dll".

and opening the test file with the argument "C:\Program Files\Parasoft\SOAtest\9.9\soatest.exe" -Zjava_home "C:\Program Files\Java\jdk1.8.0_144"

is there any simplest setting would do this.

Regards
Udaya

Comments

  • jakubiakjakubiak Posts: 269 ✭✭✭

    Simpler than that would be to update to version 9.10 - which ships Java 8 by default so you wouldn't need to pass any special arguments to control the Java version.

  • ParasofttoudayaParasofttoudaya Posts: 180

    Any settings to be changed to ignore this? Because its tough to troubleshoot, if there are some typos.

  • benken_parasoftbenken_parasoft Posts: 394 ✭✭✭
    edited August 2017

    In case this helps, if you were passing -Zjava_home to soatestcli, and had a typo where you misspelled the path to your Java installation, then soatestcli will print:

    soatestcli error: No Java virtual machine was found in the location
    
Sign In or Register to comment.