SOATEST slowness

reactancexlreactancexl Posts: 86

I am running SAOATest 9.10. It is so slow when I navigate around especially when I go to a "writeable DS" which only has one message in there. It is taking up 50% of CPU and 60% memory(i have 8 G). I have modified the settings for heap etc(see attached) . I am running 64 bit (34 was doing same thing), windows 10. I have closed down all other projects in workspace. I have read the thread on here on options of what to do, but not sure how to proceed. Any suggestions would be helpful. thx

Comments

  • benken_parasoftbenken_parasoft Posts: 397 ✭✭✭
    edited May 2017

    Do you see the problem with a new workspace? If not then issue would be specific to the particular workspace you are opening with SOAtest. Please verify you aren't keeping too many tst files open all at once. Try closing all your tst files then restarting the tool (double-click or "right-click > Close Test (.tst) File"). Please also check how many violations you have in the Quality Tasks view and try clearing those out as well.

    Concerning your Writable data source, try clearing it out if there are a lot of old message accumulated in there. Also, if your Writable data source is added at the project or workspace level, try moving it inside of the tst file that is actually using it. This way, the Writable can be freed from memory when the tst file is closed and not being used.

    Please verify actual heap usage reported by the JVM. Click "Window > Preferences > General > Show heap status" to check this. If the Java heap is running low then more CPU cycles are needed for the JVM to perform garbage collection, reducing performance.

    You can try giving Java more memory by passing and -J-Xmx argument to soatest.exe. For example, to allow Java to allocate 4GB for its help you can run "soatest.exe -J-Xmx4G"

Sign In or Register to comment.