Proxy Authentication Required for this error what kind setup we have to do?

HTTP/1.1 407 Proxy Authentication Required
Proxy-Authenticate: BASIC realm="gdc_ldap"
Cache-Control: no-cache

Comments

  • OmarROmarR Posts: 206 admin

    Good morning Sunil,

    The 407 error simply means that the client (SOAtest) must authenticate itself with the service proxy. The proxy responded back with the particular header it is looking for. Try adding your credentials in "Http Authentication" under the Transport tab.

  • jakubiakjakubiak Posts: 371 admin

    Actually this is a proxy authentication error. The HTTP Authentication section that Omar pointed to is authentication for the service, not for the proxy. You will likely need to go to the Parasoft Proxy preferences to configure the proxy authentication (Parasoft menu > Preferences... > Proxy).

  • sunil_subramaniansunil_subramanian Posts: 40

    @OmarR for soap client (simple soap request) I have used custom (only endpoint url)view in transport tab and also I have given my username and password also... Even though its throwing the same error.

  • sunil_subramaniansunil_subramanian Posts: 40

    @jakubiak thanks for ur comment... I have enableled mentioned check boxes and also gave the host and port values then filled the user name and password ( which is given in header authentication ) also. Just I want to run a simple soap request with end point URL( without WSDL/WADL)... Please help me with steps and procedures....

    Thank you

  • OmarROmarR Posts: 206 admin

    Hey Sunil,

    @jakubiak is correct in saying the configurations required will need to be made in Parasoft>Preferences>Proxy.

    You could check your IE browser settings to verify if your machine is using a Proxy:

    • Open IE
    • Click the Tools button
    • Click on Internet Options
    • Click on the Connections Tab
    • Click on LAN settings

    If so, try adding these same settings for your tool in Parasoft>Preferences>Proxy.

  • sunil_subramaniansunil_subramanian Posts: 40

    Thank you @OmarR .. Do we need to useuse above mentioned URL? Or any other URL?? If it is please post the URL

  • sunil_subramaniansunil_subramanian Posts: 40

    @benken_parasoft so no need to give http authentication in test right?? So do we need to give the proxy authentication (user name and password) under parasoft ->prefeence_->proxy ??

  • OmarROmarR Posts: 206 admin

    Sunil,

    Have you had a chance to check your IE proxy configurations? Try adding the same settings that appear in IE into the tool in Parasoft>Preferences>Proxy. These settings are specific to your network.

  • benken_parasoftbenken_parasoft Posts: 552 ✭✭✭

    Yes. The earlier reply from jakubiak has the correct information.

  • sunil_subramaniansunil_subramanian Posts: 40

    @OmarR @benken_parasoft I followed what @jakubiak posted only.. Still I'm facing same error.. And also I have checked internet options in that also I have given proxy and port detail.

  • swapna0707swapna0707 Posts: 41

    Hi Team,

    I had followed the steps which are provided in the above.

    Still I am getting error message as "proxy returns HTTP/1.1 407 Proxy Authentication Required"

    Please help me on this.

    Thanks,
    Swapna

  • jakubiakjakubiak Posts: 371 admin

    I would first verify that you are using the correct username and password. If you have done that and are still facing the problem, I would recommend you contact Parasoft support, since from the information you've given it's not clear what the issue is.

Sign In or Register to comment.