XSLT buggy

reactancexlreactancexl Posts: 139

Sometimes when I add output XSLT right under a test suite ,sometimes it works and sometimes it does not. I even changed it to a path that does not exist to introduce an error and it reads right over it. If i have it as a Test on its own I get premature end of file. I have other test suites where it works. Is there any kind of BKM when using this? thx


  • benken_parasoftbenken_parasoft Posts: 890 ✭✭✭

    It might be helpful if you can attach an example to demonstrate the issue you describe. I'm not understanding what you mean by "I add output XSLT right under a test suite". You add a tool either as a test or as an output to a test. You can add a tool directly to a suite but you have to create a reference to it (as a test or as an output to a test).

    The only other things I'd check would be to make sure the input to the XSLT Tool is XML. Otherwise, the tool will look disabled/grayed-out and won't run.

  • reactancexlreactancexl Posts: 139

    Attached is a screenshot. The input is xml. We tried shutting down and restarting and still it will not work. I do have it working on another machine which is weird as wondering if there is some config etc that is different. thx

  • benken_parasoftbenken_parasoft Posts: 890 ✭✭✭
    edited May 2017

    What is selected for "MIME type of output" in your External Tool (scroll to the very bottom)? The default is text/plain. Did you change that to text/xml?

    Also, you may need to enable "Exit value indicates success".

  • reactancexlreactancexl Posts: 139

    Good catch. It was set to text/plain instead of text/xml. It works now. Thx

Sign In or Register to comment.