Error when running CLI. (I have the CLI license)

reactancexlreactancexl Posts: 128

I am trying to run my SOATests from the CLI. Let me state my setup. SOATest is sitting on a VM (windows server 2012) with the test suite. I have admin access to the vm. I remote login to the VM and run the following cmd (soatestcli.exe -localsettings "C:\users\myname\Desktop\Localsettings -data "C:\jsf\SOAWorkspace" -resource "/TestFolder/test.tst" -config "C:\jsf\SOAWorkspace\"). I get a popup screen that says (This App Can't run on your pc. To find a version for your pc check with software publisher) I am using soatest version 9.9 and do have the CLI license. thx


  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    This sounds like an error from Microsoft Windows, not Parasoft SOAtest. Therefore, I don't see how this would be related to your license from Parasoft.

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    Make sure you are not running 64-bit SOAtest on 32-bit Windows.

  • reactancexlreactancexl Posts: 128

    we are running 64 bit OS with 64 bit SOATEst

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    Unfortunately, I can't say why Windows is showing you this error (SOAtest generally does run on Windows). As mentioned, this is a Microsoft error, not a Parasoft one, and so you may be able to find some information online about this. Beyond that, you could take some additional steps to try to isolate the problem.

    For example, does this problem only happen when opening soatestcli.exe or also when running soatest.exe? Both exe files ultimately run java.exe with some arguments. For example, it would be interesting if Windows shows the same error if you were to bypass soatestcli.exe by try running java.exe directly (should be something like "C:\Program Files\Parasoft\Test\9.9\plugins\com.parasoft.xtest.jdk.eclipse.core.win32.x86_64_1.7.0.76\jdk\bin\java.exe"). If for some reason Windows doesn't like the java.exe, as opposed to the soatestcli/soatest exe, you can always try starting SOAtest with a different Java (see ).

    Or maybe your SOAtest installation was somehow modified to run with a 32-bit java instead of the default 64-bit one shipped in the Parasoft Test location I mentioned? 64-bit SOAtest will only run with a 64-bit Java? You can also try doing a clean uninstall/re-install to see if that helps get your installation back back to a working state.

  • reactancexlreactancexl Posts: 128

    soatest.exe works. I was also able to run the java.exe from the plugins also. thx

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    You could try verifying the digital signature for soatestcli.exe, to make sure it hasn't been corrupted in some way. From Windows File Explorer, right-click the file then click Propeties, Digital Signatures tab, then Details. You should see "This digital signature is OK".

    You could also bypass soatestcli by running java.exe with the arguments soatestcli would be passing to it. It might be helpful to know if this works or if Windows still shows you the same error. soatestcli is doing something like the following, plus any addition arguments you need to pass (-data, -config, -resource, etc.):

    "C:\Program Files\Parasoft\Test\9.9\plugins\com.parasoft.xtest.jdk.eclipse.core.win32.x86_64_1.7.0.76\jdk\bin\java.exe" -cp "C:\Program Files\Parasoft\Test\9.9\plugins\org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar" -Xmx1792m -XX:MaxPermSize=256m -Dosgi.bundlefile.limit=0 -Djava.awt.headless=true org.eclipse.equinox.launcher.Main -noupdate -application com.parasoft.xtest.testcases.eclipse.core.web.WebTestApplication
  • reactancexlreactancexl Posts: 128

    when I browsed to the file soatestcli.exe to look at signature I notice the file has 0 bytes. Guess that would do it :). can I load that executable without reinstalling. or can I use a different version .exe 9.10? thx

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    You can copy soatestcli.exe from some other 64-bit SOAtest 9.9 installation. That would work, unless there are other files in the SOAtest installation that have also been corrupted or emptied somehow.

    I'm guessing that copying soatestcli.exe from a 9.10 installation into your 9.9 installation would work because all it is doing is starting Java with some arguments. However, I can't say Parasoft officially supports anyone doing anything like that.

    The safest thing is to uninstall SOAtest completely then re-run the installer. However, it would be good to understand how this happened. Please share this with us if possible. We aren't aware of any way the product corrupts itself in such a way. We can only speculate on our end (maybe antivirus software prevented the file from being written during installation?)

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    I'd recommend checking the file modification date for soatestcli.exe which will hopefully tell you when the file got emptied. Normally, the modification date would match most of the other files in the installation directory, which is the date that SOAtest was built. There are also various "unins" files which have the date when the tool was installed.

    I'm guessing that your soatestcli.exe has a modification date some time newer than the install date, like something or someone on your system corrupted the file after installation as opposed to something going wrong during installation.

  • reactancexlreactancexl Posts: 128

    ok, I got it working. Thanks for all your support. I did see that the soatestcli.exe did indeed have a modified date that was different. (?)/ I copied over another soatestcli.exe and ran the test successfully. Here is the final script that I used.

    GOTO soatestcli.exe directory (my case was C:\Program Files\Parasoft\SOAtest\9.9) then execute below script

    soatestcli.exe -data "C:\jsf\SOAWorkspace" -resource "/TestDir/Test.tst" -config "C:\jsf\SOAWorkspace\"

    -data this is the workspace where test is located
    -resource this is the rest of path to the test file
    -config this is where the local properties are located which override default.

  • sbrittonsbritton Posts: 10

    I'm having this problem almost every time I run the CLI. I'm finally getting some time to get the CLI working on my installation. However every time I run the CLI a number of times, I get the error. Same issue where the file's been corrupted, empty and overwritten with today's date.

    This is a serious issue for me and I need to get to the bottom of this because it happens every day that I've worked with the CLI.

    I've submitted another ticket to support on this. For some reason they have never heard of this issue before. I've linked this forum post again so maybe they will take notice.

  • benken_parasoftbenken_parasoft Posts: 723 ✭✭✭

    We'd love to know what actions you are taking that is resulting in the soatestcli binary becoming corrupted. I can think of easy ways to corrupt files from a command prompt but don't want to rule out any other explanation.

Sign In or Register to comment.