SSLException: HelloRequest followed by an unexpected handshake message

LegacyForumLegacyForum Posts: 1,664 ✭✭
edited December 2016 in SOAtest
If you are getting the error in this topic's title line:
SSLException: HelloRequest followed by an unexpected handshake message

Then, add the following to the command line when you launch SOAtest in Windows or Linux:

For Load Test running on Linux, add the line (less the -J option) after "exec $JAVA" in the text file named "loadtest" under <ParasoftInstallDir>/soatest/9.0/


  • LegacyForumLegacyForum Posts: 1,664 ✭✭
    Anyone know how I can fix this same error on a slave machine? I tried adding the line "" to the Parasoft Load Test service under "Properties / Start Parameters" on the slave, but I'm still getting the SSL error. Note, I also tried without "-J"
  • LegacyForumLegacyForum Posts: 1,664 ✭✭
    Hello bka,

    When you launch Load Test on a Windows slave machine, you are probably using the "Load Test 9.0 Load Test Server" shortcut in the start menu. If you right click on this shortcut, you will see that the argument "-loadtestserver" is already being used. If you wish to use additional arguments, simply add them after this one here. If you use this shortcut to launch Load Test then those arguments will be executed.

    If you are using a Linux slave machine, when you start up load test, you will have to pass the proper Java arguments in the command window.

    In summary, when launching Load Test on your slave machines, you need to use the same arguments you passed on the Master machine.

    Please let me know if this solves your issue,
  • LegacyForumLegacyForum Posts: 1,664 ✭✭

    Yes, that did it. Now the login is running without errors on the slave.
Sign In or Register to comment.