Add the active environment to my test

LegacyForumLegacyForum Posts: 1,669 ✭✭
edited December 2016 in SOAtest
I would like to know how to tell to my navigate step to get the active environment.

Since I have 3 environments were I like to run the same test. Like

www.certifiactionserver.com

www.productionserver.com

www.stagingserver.com

the main idea is run the same test over these 3 environments, since my test was recorder from a browser, I would like to add these 3 different environments to my list and the first step of the test that start with, Navigate ${production}. should be changed Navigate: ${active enviroment}.

thanks in advance,
Tagged:

Comments

  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    My understanding is that you have three environments and you want to run your scenario of tests against each of the three environments. To do this you need to define environment variables for all three environments. All three environments must have the same environment variable names. For example "${URL}" can be the environment variable name for the URL valuse you've listed. You simply replace all of the hardcoded URL values with ${URL}.

    When running from GUI mode, simply activate the desired environment and it will dereference the ${URL} variable accordingly.

    When running from CLI (command line mode), simply use "-environment" argument and specify the name of the environment you want to run against. Please refer to our documentation @ "Setting up the Automated Nightly Process using CLI". Scrolling down a bit will take you to a table of CLI commands. The one you'll be interested in is "Specify environment options".

    I would like to know how to tell to my navigate step to get the active environment.

    Since I have 3 environments were I like to run the same test. Like

    www.certifiactionserver.com

    www.productionserver.com

    www.stagingserver.com

    the main idea is run the same test over these 3 environments, since my test was recorder from a browser, I would like to add these 3 different environments to my list and the first step of the test that start with, Navigate ${production}. should be changed Navigate: ${active enviroment}.

    thanks in advance,

  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    Thanks truong!!! it works perfect
Sign In or Register to comment.