Backend testing

LegacyForumLegacyForum Posts: 1,669 ✭✭
edited December 2016 in SOAtest
Issue faced while testing oracle database
Hi,

I am trying to execute a simple SQL query from Parasoft SOA test tool for Oracle database(version:Oracle 9i, Operating system:Windows XP). But I always get the error-"ORA-01882: timezone region not found " . For any query for any table, I get the same error. The queries work fine through TOAD or SQL Plus and through few other SOA testing tools. Testing with MSSQL database does not give any issue.

Can anyone throw some light on this!

Thanks in advance!!

regards,

ParasoftM
Tagged:

Comments

  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    edited December 2016
    Hi,

    Check your Windows registry if DisableAutoDaylightTimeSet exists in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation. If it exists, either set the value to 0 or delete it completely from the registry. There's a known issue with JRE and Windows for this. Alternatively, if the provided solution doesn't work I can upload a temporary patch that may address this issue.
  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    edited December 2016
    Just to clarify, you should be checking the Windows registry of the machine with the Oracle database installed.
  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    edited December 2016
    Hi,

    Thanks for your reply!

    But, the error still exists. First I tried by setting the value for DisableAutoDaylightTimeSet as 0, then I tried by deleting it. But, the execution throws the same error.
  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    I've attached two patches in the .zip file. Please download the .zip file and extract the two jars/patches contained in the .zip file. When using one of the patches, simply place it in your SOAtest installation directory (e.g. C:\Program Files\Parasoft\SOAtest\5.5.1). They cannot both be in the installation directory so remember to remove one or the other when using them. I'd like you to first try aaa-oracle-tz-debug-set.jar. If that doesn't work, remove it from the installation directory and place aaa-oracle-tz-debug-notset.jar instead. You must restart SOAtest when placing the patch in the installation directory so that it can load the classes. Let me know how this turns out.
  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    edited December 2016
    Actually I may have misspoken earlier. You should set the DisableAutoDaylightTimeSet to 0 on the machine that SOAtest is installed on, or remove the registry value altogether. I was able to reproduce your issue, and when changing it to 0 followed by restarting SOAtest, it went away. Alternatively, the first patch aaa-oracle-tz-debug-set.jar is also able to resolve the issue for me. But if possible, could you try both solutions so we can release an official fix for this, thanks.
  • LegacyForumLegacyForum Posts: 1,669 ✭✭
    Hi,

    Thanks for your reply. The issue got resolved after setting DisableAutoDaylightTimeSet to 0 in the windows registry where the SOA Test tool is installed.

    Thanks once again !!

    Regards,
    ParasoftM

Sign In or Register to comment.