Proxy Need an PVA

reactancexlreactancexl Posts: 86

I think I know the answer but want to ask to make sure. Does a proxy need to have a PVA?

Tagged:

Comments

  • keegan_chankeegan_chan Posts: 29

    No. A message proxy does not need a PVA.

  • VirtualUserVirtualUser Posts: 4

    hi reactancexl,
    no, it does not. The Service URL could very well be a real (as opposed to a virtual) asset.

  • reactancexlreactancexl Posts: 86

    I thought that was the case so i must be doing something wrong. I can call the proxy just fine but when I try to call the real endpoint(outgoing) it keeps automatically putting in a "port" when I save. What am I doing wrong? I do pass in a parameter. Picture attached.

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 135 ✭✭
    edited February 8

    Proxy URL (the one which you are creating) will always use Virtualize Server port, as you are running such proxy on Virtualize Server.
    The real service definition will need port if is not standard.
    As you provided protocol (http in your case) proxy automatically "translate" it into default port of http.
    Do you have any problems with using 80 port when proxy send a request?

    --
    Ireneusz Szmigiel
    http://www.catb.org/esr/faqs/smart-questions.html

  • reactancexlreactancexl Posts: 86

    Here is a screenshot with more pixels. I hope you can see this one. If I read your answer about the real service port (in this case, it is an outside SOAP service) which I do not need a port as a definition in SOATest) using virtualize I need to define a port? So if that is the case then a proxy can not be used directly as a pass thru in some instances? thx

  • williammccuskerwilliammccusker Posts: 54

    Based on the screenshot was the question about why port "80" is being added to the "outgoing connection" in the bottom half of the screenshot?

    If that is the case the port "80" is being shown there to be clear about the default port will be since in the connection settings the "Service port" field was left empty. We prefer to show a port to help make it clear where Virtualize will send the request. If port 80 is not the port desired then please fill in the "Service port" field with the actual port.

    Hope this helps!

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 135 ✭✭
    edited February 8

    Even better explanation then mine @williammccusker :)

    @reactancexl You don't need a port as by default http will use port "80". However as it been said the port in proxy is only for information purposes in your case. It will not harm your communication.

    --
    Ireneusz Szmigiel
    http://www.catb.org/esr/faqs/smart-questions.html

  • reactancexlreactancexl Posts: 86

    Yes William that is correct on outgoing connection. We have a Proxy server( I have set this up on the tab on proxy) when we hit outside sites within the company. It uses 912 as the port. I can launch the url directly, from a browser
    www.webservicex.com:80/globalweather.asmx. But virtualize does not like it as I get a 404 error. thx

  • williammccuskerwilliammccusker Posts: 54

    So in you case to reach that "outgoing" service you need to use a network proxy but when you configured the settings on the "Proxy Server" tab it is still unable to reach the service?

    Could you include a screenshot of the "Proxy Server" tab?

  • reactancexlreactancexl Posts: 86

    Correct even with the proxy settings on the proxy tab with mycompany proxy server it still gives me a 404 error. We do not need a username and pswd for all other connections outside of virt, not sure if virtualize needs this? thx

  • williammccuskerwilliammccusker Posts: 54

    From what I can see it looks to be configured correctly. Would it be possible for you to contact support? I think it would be easier for someone to connect with you to investigate and gather details.

  • reactancexlreactancexl Posts: 86

    Yes, I will do that. thanks to all who responded :)

  • reactancexlreactancexl Posts: 86

    Ok, I got it working. The proxy tab I was setting it to was for the loadbalancer. For some reason virtualize does not like it but SOATest does not seem to mind. thx

  • Ireneusz SzmigielIreneusz Szmigiel Posts: 135 ✭✭

    We appreciate your cooperation.
    Thank you.

Sign In or Register to comment.