Axis2 Logs in Tomcat Folder

Hi Everyone,

I just have a few questions regarding the Axis2 log that is being generated under the tomcat folder:

  1. What is it for / What is it logging about?
  2. How do we control it? (ie. limit file size/change archive settings)

Im asking this as we recently updated to 9.10 and we noticed that, after a clean install, the file went up to 10gb

Comments

  • williammccuskerwilliammccusker Posts: 82
    edited November 2017

    We use axis2 for some of our integration and connectivity. That log file is mostly likely for some of our client code. You could try disabling the logging it by editing this file in the install

    eclipse/plugins/com.parasoft.xtest.libs.web_9.10.0.20161130/root/tomcat/webapps/axis2/WEB-INF/classes/commons-logging.properties

    In that file comment out the current logging property and uncomment the line for the "NoOpLog", below is a copy of the line to uncomment
    org.apache.commons.logging.Log=org.apache.commons.logging.impl.NoOpLog

  • lukeliwanaglukeliwanag Posts: 29

    @williammccusker Thanks. Is there any way for us to limit the file? would this be needed in case we would have any troubleshooting sessions?

    @Ramiro Martinez

  • That logging is coming from axis2 and is for generated client code. We already log any exceptions that we get when invoking a client into the product's main logs so I would not expect the axis2.log to be needed for any troubleshooting sessions.

  • lukeliwanaglukeliwanag Posts: 29

    @williammccusker okay sure will make note of this. Thank you for the explanation.

  • lukeliwanaglukeliwanag Posts: 29

    hi @williammccusker i've followed the steps you've provided however i still notice that the axis2 logs are increasing in size. I've restarted the whole machine but it is still logging. please advise.

  • Could you capture the log file while its still small and attach it here? I want to check what is being logged to see if I can figure out what controls those statements.

    Also check in the preferences if "Console" is set to High and check what settings are enabled under "Technical Support"

    Thanks!

  • lukeliwanaglukeliwanag Posts: 29

    PFA requested axis2 logs

    Console is set to "High"
    Please see below Settings for Technical Support

  • When you upgraded was the previous install completely deleted? Are you using an old workspace? If yes does the logging still happen if you use a new workspace?

  • Also I would recommend disabling verbose logging in the "Tech Support" preferences. This may be what is causing it to log at debug level.

  • benken_parasoftbenken_parasoft Posts: 551 ✭✭✭

    I would recommend disabling verbose logging in the "Tech Support" preferences

    A restart may also be needed for the changes to apply to the axis logger.

  • lukeliwanaglukeliwanag Posts: 29

    thank you, @williammccusker and @benken_parasoft i'll try these settings when i get the chance then i'll update this thread. Thank you very much

Sign In or Register to comment.