Proxy for firewall and non firewall test

reactancexlreactancexl Posts: 106

I have a project that contains tests where I need a proxy and tests that do not need to go thru proxy. I want to be able to execute the series of tests (proxy and non-proxy) under the same project. I tried using the autoproxy (obtained from IE). Not shown on pic. I set the "Proxy Exceptions" for the url (hostname only, hostname including full url). It seems logical that this should work. If I do not get this to work I guess I could move the Proxy tests to their own workspace. thx

Comments

  • reactancexlreactancexl Posts: 106

  • jakubiakjakubiak Posts: 371 admin

    What you suggested should work. Another thing that could simplify your setup slightly is to simply create two different automated test runs, one where the proxy settings are set in a localsettings file and one where they are not set. Then you can use the -resource argument in each run to run only the tests that should be part of that test run. You wouldn't need to put the tests into separate workspaces, since the -resource argument lets you control which resources should be run.

  • reactancexlreactancexl Posts: 106

    Thanks jakubiak. I do not see proxy settings as a property on the "localsettings" file when I "share" or export "All" the settings but proxy is not one of them. Is there somewhere else where this is set? I am using 9.10 version.

  • OmarROmarR Posts: 205 admin

    These proxy settings are part of your eclipse preferences which are stored within your workspace's .metadata folder. Specifically in the "com.parasoft.xtest.common.eclipse.core.web.prefs" file.

    If you open the file, you will find your proxy settings:

    I don't believe you can apply these same settings in your localsettings file, but you can give it a try :smile:

  • jakubiakjakubiak Posts: 371 admin

    You cannot apply those settings in the localsettings file - but you can copy that file into your workspace as part of your automated job. I had forgotten that the proxy settings could not be set in the localsettings file.

  • reactancexlreactancexl Posts: 106

    Yep, that is what I did and it works. thx :) :)

Sign In or Register to comment.