Parameterizing response from XML request

himanshu13himanshu13 Posts: 4

Hi,

I was trying to generate a stub, which would read the request and use its content in the generated response. I used XML data bank to collect the request parameters, and associated these parameter values in the response.

Now, when I deploy the pva and run a sample SOAP request in SOAP UI, I am getting the right response on the basis of request. But, when I change the endpoint in my desired application, which then sends a request, the response is not as expected. Somehow, the response shows the my last SOAP UI request values, but not the request values generated from the application.

Could someone please help me out with this?

Comments

  • himanshu13himanshu13 Posts: 4

    @benken_parasoft - Please help me out with this

  • benken_parasoftbenken_parasoft Posts: 658 ✭✭✭

    Somehow, the response shows the my last SOAP UI request values, but not the request values generated from the application.

    It is difficult to say exactly what is happening in your environment. However, in case this helps, the Data Banks save the last values that matched the XPaths configured for your extractions. So, if the XPaths didn't match anything in the most recent request message then they could still have the values from some earlier message.

    @benken_parasoft - Please help me out with this

    I usually only try to provide quick responses on the forum, and can't always reply right away. If you have a time sensitive issue then you could contact Parasoft Support.

Sign In or Register to comment.